Denon 2910 'green' fleshtones

Discussion in 'Blu-ray & DVD Players & Recorders' started by Diving Bear, Jan 30, 2005.

  1. Diving Bear

    Diving Bear
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I connecting my Denon 2910 through DVI at 1080i to a Philips 32PF9986. I am noticing a green 'tinge' on some faces. Is this:
    1) A tweek I need to do to the 2910? If so what?
    2) A tweek to the 32PF9986?
    3) A problem with some discs?
    4) A problem with the 2910?
    5) Something else?

    All help much appreciated
     
  2. andy c!

    andy c!
    Standard Member

    Joined:
    Jan 18, 2005
    Messages:
    65
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    HI,
    Have you used jimsans settings as a starting place?
    they are in this thread:
    http://www.avforums.com/forums/showthread.php?t=181254

    I have both a 1910 and a 2910 on demo - and there are no green tinges - just a big decision to make re which player :cool:

    PS both players are connected by dvi-dvi lead - not the supplied component-dvi adaptor...

    andy c!
     
  3. Diving Bear

    Diving Bear
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks, read with interest. I'm not getting the 'green effect' on every DVD which makes me think it may someting to do with the quality of the recording??
     
  4. andy c!

    andy c!
    Standard Member

    Joined:
    Jan 18, 2005
    Messages:
    65
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
  5. Family Guy

    Family Guy
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    It'll be a problem with the display device. Do you get the green tinge in dark scenes only? Or in light scenes only...? Or both...?
    If it's one or the other (and I suspect it will be), the coloure setting on the display need tweaking...not something I would suggest you do yourself. ISF calibration or using colorfacts would sort this out - but you'd need to enter the service menu...which could mean seriouse scope for FUBAR!!

    Also, I wouldn't reccomend using anyone else's settings. each set is different - as is everybody's viewing room. All these contribute to the way things are set, both visually and with the audio...
     
  6. gandley

    gandley
    Well-known Member

    Joined:
    Aug 31, 2003
    Messages:
    5,024
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Paradise Lost
    Ratings:
    +269
    My guess is the display is setting the wrong colour space perhaps.

    Try setting the dvd player output to 576i/p and see if the tinge goes away.

    if it does then its a display issue as its trying to display a HDTV colour space to an SD image, this some times gives a green push. try it and see
     
  7. Alan D

    Alan D
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Diving Bear are you using Region 2 or Region 1 discs (or both)? I wondered if it's a PAL/NTSC thing.
     
  8. Alan D

    Alan D
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Also using "Picture Control" [MODE button] during playback you can tweak the "Color" - which actually changes the tint of the picture (from greenish to reddish -6 to +6).
    I have a Denon 1910 and I am assuming you have the same controls on the 2910
     
  9. Diving Bear

    Diving Bear
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks alot guys. I will try this out over Monday and report back :thumbsup:
     
  10. Diving Bear

    Diving Bear
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Ok, I've had a play and I think had some success. I have dropped the DVI ouput to 720p and this seems to have improved it. I was getting really bad green tinge on Gandalf's face at the start of Fellowship of the ring and in the crash scene in Pitch Black. Both seem to play OK. Other DVDs play perfectly at full whack.
    Thanks for help.
     
  11. Diving Bear

    Diving Bear
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    OK, so now I am totally confused. I thought I had this one fixed. Played around with settings on EVERYTHING; the DVD player with the picture adjust and the settings on the Philips 32PF9986. I am still getting green flecks on exposed flesh: hands, faces etc. If I drop to 720p they go! On 1080i and 480p/576p they are there!!!!
    So what is it? The LCD? The DVD. I am tempted to get the DVD changed to see if that makes a difference.
    Many thanks for any opinions
     
  12. Loewe

    Loewe
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Dark scenes look green on my Denon 1910 on DVI. Very irritating. Scart/RGB and S-video is fine. Haven't tried component, but i bought the player because of the DVI..

    It could be my TV (Sharp LC37GA), but the black horizontal bars over/under the picture (on films wider than 16/9) look perfectly black though. And Jpegs look perfect, I think, via DVI. This is where this player truly shines by the way, just like using a PC!

    Maybe new firmwarefix is under way, that fixes the green tint in the blacks? And hopefully makes you play 4/3-films via DVI without stretching them. I bought the player in december and got it upgraded then. Any suggestions?
     
  13. Marky Badger

    Marky Badger
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I am getting the same thing. TV is Philips 32PF9976 (LCD) connected via a QED-branded HDMI to DVI lead to Sony RDR-HXD910, upscaling to 1081i. I get green speckles on skin or flesh-like colours. It disappears on 720p but this isn't full screen so not really acceptable. So sounds like a Philips problem. Have tried turning on and off Pixel Plus, dynamic contrast, etc but to no avail. It seems to be worse on poor reception Freeview. Any suggestions?
     
  14. ozdvduser

    ozdvduser
    Active Member

    Joined:
    Apr 21, 2003
    Messages:
    170
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    At The Track or Melbourne Victoria Australia
    Ratings:
    +3
    Upgrade firmware to 6720-A or better, DVI/HDMI changes improve the "green tinge" substantially. Once upgraded use DVE to do a calibration via your display devices settings, if at all possible leave the 2910 settings at Factory Default (0) - the only one you may want to use is the HUE to around +1/+2 depending on your display device
     

Share This Page

Loading...