1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Denon 2805 problem - no power!

Discussion in 'AV Receivers & Amplifiers' started by Unlight, Nov 3, 2004.

Tags:
  1. Unlight

    Unlight
    Active Member

    Joined:
    Jan 6, 2003
    Messages:
    1,438
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    38
    Location:
    Belfast
    Ratings:
    +9
    Hi guys,

    I got my denon 2805 about a month ago and have only been giving it very light use (its maybe only done about 10 hours so far).

    When I went to watch a DVD earlier, there seems to be a problem, when the amp is in standby, there is usually a little red light around the power button, which changes to green whenever you switch it on. However, there is no light whatsoever, and the thing wont switch on...

    Any ideas? I'm really puzzled to what could have caused this!
     
  2. swarrans

    swarrans
    Standard Member

    Joined:
    Dec 21, 2001
    Messages:
    404
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Location:
    Kent, UK
    Ratings:
    +0
    At the risk of stating the obvious (because as you'll see from my other posts I'm having "obvious" understanding issues with this amp too!) have you pressed the smaller on/off button to the right of the one you describe?
    I couldn't get mine to power up either until my wife pointed it out!
    -- God with all these confessions I'm going to be eligible for dimwits anonymous!

    If your problem is something more major please excuse me for thinking anyone could be as dense as me!

    Simon
     

Share This Page

Loading...