Denon 1920 locking up!

Barney_Tabasco

Standard Member
I've just got a new Denon 1920 and twice now it has just locked up when in standyby mode (with the red light on around the power button). Basically it will not turn on or eject DVDs or anything at all. I have to unplug it to get it to start up again properly which is a pain as i have hidden my plugs.

Anyone else experienced the same thing?
 

Reaperman

Active Member
Barney_Tabasco said:
I've just got a new Denon 1920 and twice now it has just locked up when in standyby mode (with the red light on around the power button). Basically it will not turn on or eject DVDs or anything at all. I have to unplug it to get it to start up again properly which is a pain as i have hidden my plugs.

Anyone else experienced the same thing?

Personally I would contact the shop you bought it from and ask for an exchange..;)
 

knotpc

Active Member
Barney_Tabasco,

I've had mine nearly six months now and is used around 3hrs a day. Yet to lock up.
I know I'm going regret saying that :rolleyes: .

Regards
knotpc
 
Are you using HDMI - if so you've found a known bug in the firmware, the latest firmware fixes this issue and there's a workaround I can't quite remember (hopefully someone will post)


Barney_Tabasco said:
I've just got a new Denon 1920 and twice now it has just locked up when in standyby mode (with the red light on around the power button). Basically it will not turn on or eject DVDs or anything at all. I have to unplug it to get it to start up again properly which is a pain as i have hidden my plugs.

Anyone else experienced the same thing?
 

Henry

Active Member
Jordans Norks said:
Are you using HDMI - if so you've found a known bug in the firmware, the latest firmware fixes this issue and there's a workaround I can't quite remember (hopefully someone will post)

I've got the same problem. Any idea where to get hold of the latest firmware?
 

james_19742000

Active Member
I've got the same problem. Any idea where to get hold of the latest firmware?

Did anyone find where to get the latest firmware to fix this issue as mine has started doing it now and getting a bit annoyed by it!

Thanks, James.
 

ianfretwell

Active Member
The latest firmware v1.24 can be downloaded from here :-

http://denon.seizethenight.nl/

The file is a zip which must be extracted. It contains an ISO image file which you must burn with a program such as Nero Burning ROM (remember to use the burn image option - burning just the file to the disc is NOT the same thing and will not work).

Read the readme.txt file for more details....
 

kb33

Active Member
I just used the Windows XP software to burn my disk and everything worked OK
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom