Denon 1910 / 2910 (May contain spoilers)

Discussion in 'Blu-ray & DVD Players & Recorders' started by paulfoley, Oct 4, 2004.

  1. paulfoley

    paulfoley
    Well-known Member

    Joined:
    Sep 17, 2003
    Messages:
    3,423
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Hants
    Ratings:
    +107
    Warning – Reading this may stop some people enjoying their films & instead start searching for problems, if you feel this could be you then click Back now !


    I know that a few of you have already obtained one of these players. I was hoping to buy one this week but have seen reports of several problems over on the AVS Forums.

    Minor problems (1910 only) - DVI Handshaking Problems. Basically the Player is refusing to handshake properly with the PJ. Some owners are returning them.

    Green push / tint on black colours. This one I imagine can be tweaked out ?

    Main problem (Seems to affect both) - Macroblocking on certain scenes when outputting via DVI. The problem results in shimmering / flashing squares mainly in dark scenes or large expanses of colour.

    Info / Quotes from US Owners :

    “The DVD-1910 exhibits the macro-blocking problem that became infamous with the 5900. The Samsung 931, Yamaha S-1500 and Zenith 318 also have this issue.”

    “While watching Star Wars Episode 4 tonight, I noticed lots of macroblocking on the Denon 1910 at DVI/HDMI 720p into Mits WD52525 DLP RPTV. Lowering the Denon brightness (and/or the TV brightness) made the artifact disappear. Granted this was at the expense of losing some detail in the blacks... but to me at least, it was better than watching the dancing blotches.”

    “Bugs Life (Chapter 22) - Watch the sky (black sky) and look for "moving boxes", is the best way to describe it. “

    “It seems to me that given the choice of a) seeing the macroblocking artifact or b) sacrificing some black level detail, it might be preferrable to just lower the brightness control until the macroblocking is sufficiently minimized.

    “Macroblocking errors found so far

    - A Bugs Life, Chapter 22 , in the night sky
    - Star Wars Episode 4, opening scene, in the stars around the scrolling prologue text
    - Matrix Reloaded, chapter where Belluci first appears with the group sitting down at table.
    - The Punisher (2004), towards end of movie where John Travolta is in a limo after the railroad bridge scene.
    - Final Fantasy chapter 14, where it show the alien planet blowing up, all the stars in the black background of space
    - American History X, when the guy returns home from jail, talking to his mom in the bedroom. red walls in the background”


    For those owners who have one :

    A) Have you seen this Macroblocking bug ? Did you need to lower brightness to hide it?
    B) Did you see / tweak out the Green Push ?
    C) Has anybody successfully paired one with a Panny AE500 PJ via DVI ?
    D) Did you think that PQ improved when upscaled to 720P through DVI than say a progressive component signal ?

    Cheers Guys !

    :smashin:
     
  2. paulw77

    paulw77
    Active Member

    Joined:
    Nov 18, 2000
    Messages:
    532
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    Wigan
    Ratings:
    +42
    I only briefly tested my 1910 via DVI (to a Sanyo PLV-Z2). The handshaking problem did not exist - I did have a problem where the image did not fill the screen, but I fixed that in the Z2 service menu (see my separate thread).

    I did not notice any macroblocking, but as I said, I did not test extensively via DVI.

    I am awaiting a 7.5m DVI cable from Lindy. I should have it later this week, when I will do more testing.

    I will have a look at Star Wars tonight, but it will be via component. That is the only DVD I have from the list.
     
  3. paulfoley

    paulfoley
    Well-known Member

    Joined:
    Sep 17, 2003
    Messages:
    3,423
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Hants
    Ratings:
    +107
    Thanks for the reply.

    I think the MB only appears when using DVI. Did you see any Greeny Blacks ?

    Anyone else ?

    :confused:
     
  4. paulw77

    paulw77
    Active Member

    Joined:
    Nov 18, 2000
    Messages:
    532
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Location:
    Wigan
    Ratings:
    +42
    No I didn't.

    Full report later this week !! Stay tuned !
     
  5. andy_pandy

    andy_pandy
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Denon have done it again....these guys should learn to walk before they can run rather than keep on producing expensive equipment for US to test for them....they should be paying us....Denon :nono:
     

Share This Page

Loading...