Dell XPS 13 - Windows 10 - 512gb - Solution / Rant

Dancook

Distinguished Member
Well since I got my XPS 13 a couple of months ago I was unable to install Windows 10, I tried all sorts followed lots of online suggestions - nothing!

Problem was when installing Windows 10 and you get the white circle with install percentage it stays at 0%. The copying file in the bottom left sticks at around 2% but if left for hours on end can creep up to perhaps 6%.

I contacted Dell this week on Tuesday, explained everything I'd done - and that some forum threads suggest it's related to the 512gb. Since my wife has the same laptop but 256gb, installed windows 10 no problem, it seems quite the possiblity.

Dell said they would send an engineer with a new hard drive, I have a next business day service! But the hard drive was out of stock, it would take 2-3 days to come in. So called this morning and was told it still wasn't instock and they had no ETA. But in 10 days there would be a firmware made available for the hard drive which will solve my problem.

The laptop came with 8.1 sure, but Dell advertises the laptops as Windows 10 ready. When you go to their driver website, it tells you, you can install windows 10.. etc.. etc.. so it's not beyond expectation I should have a laptop that I can install windows 10 on. Annoyed it's taking over two months to get to this stage.

so yes, solution = wait for the firmware...
 

MacrosTheBlack

Well-known Member
I don't think a new hard drive will help you out at all. A new solid state drive might though.
 

The latest video from AVForums

AVForums Movies Podcast: Streaming Theatrical Releases And The Future Of Cinema
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom