Death of Arcam DV88+

Discussion in 'Blu-ray & DVD Players & Recorders' started by Bernard Barnett, Sep 26, 2003.

Tags:
  1. Bernard Barnett

    Bernard Barnett
    Active Member

    Joined:
    May 16, 2002
    Messages:
    671
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Norfolk
    Ratings:
    +5
    My three-month-old Arcam DV88+ appears to have died. I switched it on last night, or rather attempted to, and nothing happened, no lights, nothing. Disconnected from the mains and reconnected - still nothing. Checked the fuse in the plug and it's not that. Tried a different wall plug but it's not that either. I'm going to take it back to the shop this morning but wondered if anyone had had a similar experience. Also if anyone knows what my rights are in asking for a loan machine while it's being fixed (probably none).
     
  2. Craig Sowerby

    Craig Sowerby
    Active Member

    Joined:
    Nov 14, 2002
    Messages:
    313
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Ratings:
    +26
    Hi,

    You cannot force the store to loan you a machine, but i would'nt
    think you will have to try, a good dealer will probably offer you one anyway, but if not just ask.

    I have never had a DV88 die like that.

    Good luck anyway.
     
  3. Matt Horne

    Matt Horne
    Member

    Joined:
    Nov 20, 2000
    Messages:
    4,117
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    83
    Location:
    Over the Hill & Far Away
    Ratings:
    +119
    Sounds like the internal power supply has gone bang ?. I have never got a loan machine out of my dealer.. always some crap excuse. But Arcam are usually very quick in turning the repairs around.. or maybe try and twist the dealers arm for a new one ?
     
  4. Bernard Barnett

    Bernard Barnett
    Active Member

    Joined:
    May 16, 2002
    Messages:
    671
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Norfolk
    Ratings:
    +5
    Thanks Craig/Matt. Yes, probably blown an internal fuse. Took it into the shop and they're sending it to Arcam. Couldn't predict how long it would take. And sure enough, crap excuse about no loaners.
     

Share This Page

Loading...