DAVS 550 Subtitle Problem

Discussion in 'Blu-ray & DVD Players & Recorders' started by GeordieKeith, Jan 6, 2003.

  1. GeordieKeith

    GeordieKeith
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have checked the threads but can't see that the problem is explained. Can someone please let me know what it is so I can check my system.

    Thanks
     
  2. Ashy

    Ashy
    Member

    Joined:
    Jan 3, 2003
    Messages:
    377
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +14
    Hi mate

    The problem from what ive experienced is that the subtitles are always on at the start of a movie, and during the layer change the pop back on sometimes with a pause to the movie itself.

    Hope that helps, im going to try and get mine fixed soon.

    Give the number on www.sony.co.uk a call and they will direct you to the nearest repair place.

    Ash
     
  3. Jasonjo

    Jasonjo
    Well-known Member

    Joined:
    Dec 3, 2001
    Messages:
    2,677
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    UK
    Ratings:
    +115
    ...a firmware upgrade is needed to cure the problem...
     
  4. GeordieKeith

    GeordieKeith
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    :blush: Sorry I am having a thick day. Does anyone know how the machines are made multi-region? Is it a chip?
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice