CXN v2: Plex shows in media library on device, but not on app

chriss80

Novice Member
Hello! While my Cambridge Audio CXN v2 is great for many things, I've had some frustrations with it, particularly streaming my music library. I have my library on a WD MyCloud EX2 Ultra NAS drive and I'm using Plex with DLNA enabled. The weird part is that I can see and stream my Plex music library if I look on the box itself, but it rarely shows through the Cambridge Audio Stream Magic app (on iPhone 11). Oddly, it does normally show on the older CA Connect app (although the app itself is clunky and takes a long time to load the music library). It seems hit and miss as to whether I can control the library through the Plex app using the CXN's Chromecast function.

I'm not wedded to using Plex (but I don't want to change the NAS drive). I've disabled "Twonky" on the NAS (I previously had a bit more joy with WD's native DLNA, but this is no longer available after a firmware update). I've checked I'm running the most current firmware on the CXN.

Any suggestions? I tried Cambridge Audio customer services, but they just said to check the Plex settings. Thanks!

(The next challenge will be to get the CXN to display the track artist from the metadata, rather than the album artist...)
 

larkone

Distinguished Member
A lot of app issues can be sorted by uninstalling, reboot and re-installing
 

chriss80

Novice Member
From browsing through the forums, I've tried the mconnectLite app to see if that works. It also does not "see" the Plex server on the NAS. I can access the NAS through the iPhone "files" app after adding the server IP address and through the My Cloud app. I appreciate this thread may now be in the wrong place if it's an iPhone / Plex / NAS issue, rather than a CXN issue (which is connected to Plex).
 

Cebolla

Well-known Member
It's not clear if the problem is due to Plex not properly getting its built-in UPnP/DLNA media server to announce itself on the network as a UPnP/DLNA device, or if the NAS is not allowing Plex's UPnP/DLNA media server to be discovered as a UPnP/DLNA device, or even if the network management system (eg your router) has a general issue with UPnP/DLNA device discovery.

Is your NAS connected to the network in the standard way, ie, by ethernet cable to a router or a switch?
If not, how exactly is it connected to the network?

If so, what is the make/model of the router or switch that the NAS is connected to and also, is the CXN connected to the network in exactly the same way, so by cable to the same network box?
If so, is the mconnect Player app picking up the CXN with no problems or If the CXN isn't connected by cable to the same network box, could you do so and test to see if the mconnect Player app has no problems seeing the CXN & report back?
 

chriss80

Novice Member
Hi Cebolla - thanks so much for this.

The NAS is connected to the router by ethernet cable. The router is Plusnet's Hub One (BT Home Hub 5A). The CXN is connected by wifi (I understand CXN only supports 2.5GHz) and the mconnect is picking up the player and I can stream music that is on my iPhone with it.

I've done something I should have tried months ago and installed the Stream Magic app onto a Lenovo Android tablet I have that I rarely use. That did identify the Plex Media Server at first - although it's now searching for it and doesn't seem to be able to find it (which is something I haven't seen on the iPhone app). The iPhone and Android tablet are connected to the same wifi network and there are no active VPNs on either.

All the while, the CXN v2 has access to Plex if I use the controls on the box itself.

I do wonder whether there's an issue with the router not granting (or inconsistently granting) the phone / tablet access to the NAS through certain apps, given that the apps are almost always connected to and able to control the CXN - but I'm not really sure where to start with this.
 

Cebolla

Well-known Member
BT's range of Home Hub routers have had a history of UPnP device discovery issues, especially with UPnP devices on the wired part of the network trying to find UPnP devices on the wireless part of the network and vice versa.

Given that Plusnet's Hub One is a rebadged BT HH5, it's likely that's what's happening on your network. It would explain why the UPnP/DLNA controller apps running on the wireless devices can see the wirelessly connected CXN UPnP/DLNA streamer, but not the NAS's UPnP/DLNA media server which is connected by wire to the network.


From what I've seen mentioned before about the both the HH4's & HH5's UPnP device discovery issues is that the problem is much improved if not resolved altogether if you separate the router's 2.4GHz & 5GHz WiFis from each other by not giving them the same name, plus only use the 2.4GHz WiFi for your wireless devices that are involved with UPnP streaming - for example, see:
MinimServer Forum - Control point response
 
Last edited:

glenhb

Novice Member
Have you got DLNA enabled in PLEX?
Go to :-
Settings icon (top right spanner symbol)
Scroll down to settings on the left hand menu
Select DLNA option
Check that the "Enable the DLNA server" box is ticked
If it is already ticked, untick it to turn it off and the re tick it to turn it back on.

I'm running PLEX on a PC and have no problem accessing my music files via my CXN V2 either directly on the CXN or using my phone / tablet.
 

The latest video from AVForums

Podcast: Hisense A7G, Zidoo Z1000 & Kudos Cardea C10 Reviews + Movie News and Reviews
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom