crank 2 sony 350

serge

Standard Member
hi i just put in crank 2 in my sony bd350 a yellow box come up with a serirs of lights underneath showing loading film it camr to first red light then freezed pic is running but tiny in box i have done a update but still same i tried it on my ps3 says i need update on film not ps3 i clicked no and it worked fine
any ideas
i know film is prob. crap but
i dont want this to happen to other films i get in future
 

emthree

Active Member
I think disc tries to connect to internet for BDLive or something. If you are wi-fi or wire connected, it may work faster; otherwise, even on my Oppo, it too quite a while for it to load. Seemed as if it is frozen on those yellow-red lights, but eventually loaded.
 

petet66

Active Member
I seem t orecall another post relating to this disc whereby a user couldn't get it to play until they had some external memory in their player as well as being able to connect to BD Live!. Have you tried this?
 

Beddie

Active Member
just buy a 1Gb usb memory stick and plug it in the hole in the back of the player. The film then play perfectly.

You will need quite a small stick as there is not a huge amount of room round the back to insert it.
 

petet66

Active Member
Can you use a USB extension cable to plug in larger stick?
 

Beddie

Active Member
Can you use a USB extension cable to plug in larger stick?

I haven't tried it but I'm sure it would work. I used a Kingston drive which are just "normal" sized and it worked, but I have a chunkier one that didn't fit.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom