• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Question Cracking Static Sound in Left Channel

Elvenmunky

Established Member
I am getting a crackling/static sound in the left channel of my reciever. It came out of nowhere and it's really annoying. It's a brand new receiver (Denon AVR-X2500H) and about a month old. Do I need to return it?
 

dobrykamil

Distinguished Member
Sounds like a hardware problem to me. Cracking sound could be coming from digital or analog audio circuit. The easiest way to find this out, is to feed analog signal say to CD input, and set av receiver to Direct mode. I've had in the past an Onkyo TX-NR414 in my workshop, with exactly the same symptoms, caused by faulty volume/input selector chip. You could try a factory reset as well.
 

Elvenmunky

Established Member
Sounds like a hardware problem to me. Cracking sound could be coming from digital or analog audio circuit. The easiest way to find this out, is to feed analog signal say to CD input, and set av receiver to Direct mode. I've had in the past an Onkyo TX-NR414 in my workshop, with exactly the same symptoms, caused by faulty volume/input selector chip. You could try a factory reset as well.

Thank you.

I have tried a factory reset and tried using a different wire and speaker but unfortunately the crackling still occurs. Looks like a return for me :(
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom