Coverflow Duplicating Album Art

Discussion in 'Headphones, Earphones & Portable Music' started by MickEP, Jan 30, 2009.

  1. MickEP

    MickEP
    Active Member

    Joined:
    Dec 8, 2005
    Messages:
    499
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Blackpool
    Ratings:
    +96
    Hi,
    I have recently applied cover art to my mp3 Albums using MP3Tag, but when I use itunes the cover art is repeated several time for different tracks (but not all the tracks on the album)
    Hope the above makes sense.
    I have attached a picture to hopefully make my explanation a bit clearer.
    Has anyone got any ideas why this is happening or what I have done wrong ?
    Thanks Mick

    [​IMG]
     
  2. adriandg

    adriandg
    Novice Member

    Joined:
    Oct 27, 2005
    Messages:
    400
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +1
    You need to make it part of a compilation. To do this highlight all the tracks on that album, then right click and choose "get info". You then need to navigate to the tabs at the top which from memory I believe is organisation, if it's not it something like that. Then you will see a series of boxes about half way down is "part of a compilation" choose yes and then ok and sync your ipod. It should then appear as one entry in cover flow.

    Hope this helps
     
  3. MickEP

    MickEP
    Active Member

    Joined:
    Dec 8, 2005
    Messages:
    499
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Blackpool
    Ratings:
    +96
    Thanks for the reply adriandg :smashin:
    I will give that a try when I get home tonight
    Thanks again
    Mick
     
  4. ChrisAV

    ChrisAV
    Active Member

    Joined:
    Dec 5, 2008
    Messages:
    766
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    43
    Location:
    Wirral
    Ratings:
    +110
    Yes, do as adiandg, the tick box is on the 'info' tab, bottom right.

    Also, if you have albums with one main artist and one or more collaboratios (e.g. U2's with BB King - when love came to town), can't use this method as it changes the artist to 'Various' in cover flow. Instead select all tracks on the album, go to get info (as before), but this time go to the 'sorting' tab and in the right hand column put the name of the main artist you want displayed in the 'Sort Artist' box.

    Chris
     
  5. Palladio

    Palladio
    Active Member

    Joined:
    Sep 11, 2003
    Messages:
    1,208
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Essex, UK
    Ratings:
    +143
    Great post Chris as I 've been changing Artists and Album artists to get round this very problem. Will now try the 'sorting' tab. :thumbsup:
     
  6. MickEP

    MickEP
    Active Member

    Joined:
    Dec 8, 2005
    Messages:
    499
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Blackpool
    Ratings:
    +96
    Sorted!!
    Thanks for your help guys :thumbsup:
     
  7. Autopilot

    Autopilot
    Well-known Member

    Joined:
    Feb 5, 2005
    Messages:
    7,630
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Region 2
    Ratings:
    +1,517
    As you are using the excellent MP3tag - in future set an extended tag to the album call ITUNESCOMP and set it to =1. Then itunes will also group them automatically when you add it to your library.
     
  8. rodney_nz

    rodney_nz
    Active Member

    Joined:
    Jun 3, 2004
    Messages:
    105
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +3
    Thanks for this thread, seems to have helped me out too but is there any reason why you need to do ITUNESCOMP? I added the field BAND and just set to BLANK and it seems to group them even if ITUNESCOMP is not set to 1

    cheers
     
  9. voodooflux

    voodooflux
    Active Member

    Joined:
    Nov 2, 2002
    Messages:
    267
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Redditch, UK
    Ratings:
    +12
    It looks like the extended tag is called ITUNESCOMPILATION - at least that's the tag that the "Get Info" function of iTunes sets when the "compilation" flag is set to "yes". I just used MP3Tag to set this directly on the files and it worked.

    Very relieved to have found this thread - been tearing my hair out over this.
     
    Last edited: Apr 9, 2009

Share This Page

Loading...