• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Could bracket have killed my pj?

Docta teef

Established Member
I ve been using a book case for my projector (an H56) for a couple of weeks but at the weekend i ordered an LMP universal mount. Ive mounted the main part of the bracket no prob but when it came to the face plate i noticed that the screws to connect to the projector where rather long. As a result i used the 12.5mm spacers plus washers. Even so the screws needed to go a very long way into the pj. When i came to test the pj it started up fine but could not find any signal from the component(vGA) input. Ive tried every other input source but not signal. I know that the component lead is ok as ive connected an lcd tv and that works fine. Is it possible that these long screws could have damages one of the circuit boards inside. Is so what the hell do i do and any idea what its gonna cost.
 

RTFM

Established Member
One of my customers did the same thing using bolts too long on an NEC DLP projector I sold him a few years back.
I told him to bring it back and I would have a look.

Upon stripping down the projector I found he had shorted the main PCB to ground and blown an internal fuse. It had also distoted the PCB and cracked it but I was able to repair the PCB, re-assemled it and it worked fine.

So yours may not be too bad to fix.

Jeff :rtfm:
 

RTFM

Established Member
Probably best to track down a local a/v company or the people you bought the projector from.

Jeff :rtfm:
 

Cheddies

Standard Member
The first thing to do would be to call/email the person who sold it to you and see what they say/who they recomend for repairs
 

maverick177uk

Distinguished Member
Why don't you try sevenoaks they are friendly and could probably give you advice, they are near the Arnadle in Manchester :)
 

avanzato

Established Member
Has the PJ got a factory reset switch? I lost the component in on my Z1 when fiddling around with cables and a press of the reset switch cured it.
 

Docta teef

Established Member
Cheers guys

Cheedies i bought the pj off Rob Tarn who was a member but has moved down under

Maverick have thought seven oaks may be an idea

Avanzato will check this first but doubt i will be so lucky i dont think ive done much damage as the pj still functions but will not get input its just an expensive spot light at the mo
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom