Configuring LG TV as External Monitor


Standard Member
I'm trying to configure an LG TV (22LG30R) as external monitor for my MacBook (second generation). I've tried two different setups:

1) RGB connection
In this mode, the maximum resolution is 1680x1050. However, the image is blurry and I can see dark shadows around texts and window borders. I've taken a picture to show what I mean:

(Notice the black shadow around the letter "L" and the LG logo, specially on the right side)

2) HDMI connection
In this mode, the maximum resolution is 1920x1080 (interlaced or progressive). However, the output image is not full screen, even though this is the maximum resolution for the external monitor. There are black borders on the four sides of the screen. If I tick the zooming/scaling checkbox under the TV output options (in Mac OS X), the external image becomes bigger than the TV, making the upper and lower menus disappear.

In all cases, I'm using the extended monitor configuration (different resolutions for the external monitor and the MacBook screen). I've tried to configure the external monitor in both Mac OS X 10.5 and Windows Vista, but the result was the same.

Is there any way to configure the external monitor properly? Why are there black borders even though I'm using the TV's maximum resolution?

Thanks a lot,


Novice Member
Try using the TV's NATIVE input (not necessarily the maximum it can accept) this will allow the TV to match pixel for pixel which SHOULD mean you don't get any black bars or borders AND the text should look crisp...


Standard Member

How do I find out what the native resolution is? Should I use RGB or HDMI mode? The TV manual lists the following resolutions:

Supported Display Resolutions in RGB Mode
640 x 480
800 x 576
1024 x 768
1280 x 1024
1680 x 1050

Supported Display Resolutions in HDMI Mode
720 x 480
720 x 576
1280 x 720
1920 x 1080i
1920 x 1080p



Distinguished Member
the native resolution of that tv is 1680 x 1050


Standard Member
Yes, the resolution 1680x1050 (RGB mode) seems to be the best option. I found out that the black shadow was caused by my poor-quality cable. I bought a new one and the image is much better!


The latest video from AVForums

Panasonic LZ2000, LZ1500 & LZ980 Hands-on Launch Event | No QD-OLED for 2022, new 77-inch for LZ2000
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom