1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Completley Baffled

Discussion in 'Projectors, Screens & Video Processors' started by ErikJDurwoodII, Sep 19, 2004.

  1. ErikJDurwoodII

    ErikJDurwoodII
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Okay. The company I work for purchased a gigantic projection monitor at an auction. They dismantled it and put the housing in the basement but left the projector in the storage room. I got hired here and found it back there while doing inventory. It has no brand but was "Made in Belgum by BARCO" and has the model "RETROBLOCK G808S" I can't find any information for that model, so I assume it's a Barco 808s. Graphics, or Data, I don't know. I'd like some input is anyone knows about this spin off model. It also has the logic boards on top of the tubes rather than behind them (making the unit a cube) but everything in it is identical to the Barco 808s Manuals.

    Anyhoo. I'm having an odd problem with it. I hooked it up and turned it on, but there's no picture. However, there are also no error lights. I looked at the light panel next to the DIP switches and everything is great. I look at the boards' LEDs and they're all green. (the Vertical Deflection module had a RED LED on when I disconnect all signar from the unit) I open up the back panel to reveal the ends of the tubes, and each tube's LEDs are lit, and the necks of the tubes give the dim glow like they should. I just get no picture whatsoever.

    It's very confusing. I want to fire it up to see how many hours are on the system, but I see no image, or menu, or anything. But the LEDs think everytrhing is fine ^__^.

    Thanks for reading and I'd appreciate any input I can get.
     
  2. Roland @ B4

    Roland @ B4
    Active Member

    Joined:
    Apr 11, 2001
    Messages:
    2,238
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Reading.
    Ratings:
    +32
    Erik
    this is what barco called an OEM block. what you have is effectivly is a barco graphics 808s in an L shaped box. these were always made to order and had a variety of lenses available depending on screen size. almost all were set to run on axis for rear projection. On the sticker that you saw it will give the angle of use.

    To your problem though I recon your PJ is going into EHT hold down.probably becaause the EHT quadrupler has failed.
    Behind the series of green LEDs that you found is a black plate held on with two silver slot screws. It has white writing on it and will be above a gray box with the big red EHT leads coming out. switch the projector on. Can you see a red LED on inside that card?
     
  3. ErikJDurwoodII

    ErikJDurwoodII
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    The red led on that card IS illuminated when the projector is running.
     

Share This Page

Loading...