Colour problem windows 11 hdr sony x900h

SnakePlissken006

Active Member
Hi,
I've been having a problem for a while with really crushed blacks and bright whites on my gaming pc. This causes great loss in detail in many games and causes effects like smoke, fog and lighting to look broken. I'm using a 3080ti connected to my sony x900h with a hdmi 2.1 cable. Detail is crushed in many games and light has a halo effect. Some hdr games look OK but mostly sdr games look bad. I have tried changing both tv and pc to sdr for them but the effect is till there and its definitely not my tv as I have tested the exact same games on console using the same tv and it looks fine on that. I tried reinstalling graphics drivers and windows 11 too. I tried a different hdmi port and cable but still the same. I've included an example of dead space 2 in both hdr and sdr, hdr is the one with two pictures. Does anyone know how i can sort this? Thanks
 

Attachments

  • 20220329_210211.jpg
    20220329_210211.jpg
    282 KB · Views: 23
  • 20220329_210318.jpg
    20220329_210318.jpg
    229.3 KB · Views: 20
  • 20220329_210704.jpg
    20220329_210704.jpg
    250.7 KB · Views: 21
  • 20220329_210506.jpg
    20220329_210506.jpg
    186.6 KB · Views: 21
  • 20220329_210932.jpg
    20220329_210932.jpg
    372.5 KB · Views: 23
  • 20220329_211019.jpg
    20220329_211019.jpg
    354.2 KB · Views: 29

sykotik

Distinguished Member
Is the TV set too PC mode on the hdmi port?
If that doesn't work ( in the 4th pic )
change the output too nvidia settings, and have a play around with colour settings.
Not saying it will work , but in the past iv had to change the colour settings as I was getting colour banding.
 

SnakePlissken006

Active Member
I've tried all nvidia settings in both 12 bit and 10 bit hdr. Tried rbg and other colour methods also tried changing tv and nvidia to limited rpg instead of full but still the same.
 

next010

Distinguished Member
Does it happen even with plain SDR 8-bit RGB 4K 60hz enhanced mode (no VRR), if so then it might be windows 11.

One way to verify is to not use windows.
1) Download ChimeraOS which is game console style linux OS that runs Steam big picture.
2) Use balena etcher to write the ISO to a USB drive.
3) Disconnect internal SSD (that has windows on it) if you wish to keep current install.
4) Connect any other spare HDD/SSD and boot PC using USB drive then install ChimeraOS to the internal drive.
5) Login to Steam, go to settings/features/Steam Play and enable for all other titles, select proton 7.x official (dont pick bleeding edge).

Now try some of the same games, your not going to get HDR support so its SDR only.
 

rhodos

Well-known Member
Honestly not trying to scupper the thread but I've assumed in my 12 months with a gaming PC that HDR isn't really mature for PC gaming. i.e. Windows doesn't know/handle well when it has HDR content and thus I leave it off.

If someone like an AVF video-guru or HDTVTest or the folks at Digital Foundry did a piece to say its now mature in Windows 10/11 and you'll get the best results just leaving it on then I'd be in that queue in a flash.
 

sykotik

Distinguished Member
Can you rename the hdmi input ?
Sometimes like on sammy tv and lg ones the hdmi can be called PC , console

Or have you tried turning off game mode ?
 

SnakePlissken006

Active Member
Yeah I've tried all other modes on tv but still the same. I've also tried renaming hdmi. It's currently on game but others make no difference. Here's another example of black mesa. Exact same results with both pc and tv set to sdr at 8 bit.

 

SnakePlissken006

Active Member
It seems like the pc is displaying too much contrast for my tv to handle or something therefore crushing detail in whites and blacks? I really have no idea. If you notice that windows says my peak brightness for x900h is 994 nits but apparently its only 600. Here's another screenshot of cru displaying my tvs max luminance and min luminance. I have no idea if they're correct but maybe if I change it manually it could help?
 

Attachments

  • 20220330_113807.jpg
    20220330_113807.jpg
    414.8 KB · Views: 23
  • 20220330_113716.jpg
    20220330_113716.jpg
    383.7 KB · Views: 20

next010

Distinguished Member
Yeah I've tried all other modes on tv but still the same. I've also tried renaming hdmi. It's currently on game but others make no difference. Here's another example of black mesa. Exact same results with both pc and tv set to sdr at 8 bit.



If your getting this even in 8-bit SDR, then I would suggest trying the linux OS I mentioned above, that will at least tell you if its a software problem or a hardware problem.

You've ruled out the TV with the game console on the same input so if it persists in linux then you may have a GPU/hardware issue.
 

SnakePlissken006

Active Member
If your getting this even in 8-bit SDR, then I would suggest trying the linux OS I mentioned above, that will at least tell you if its a software problem or a hardware problem.

You've ruled out the TV with the game console on the same input so if it persists in linux then you may have a GPU/hardware issue.
Sorry I'm not interested in downloading Linux I need Windows.
 

next010

Distinguished Member
Sorry I'm not interested in downloading Linux I need Windows.
The point it to test and see if its the hardware, not use it permanently.

You've stated you have clean installed windows and the problem persists, your not going to get an answer if its the hardware with windows.
 

SnakePlissken006

Active Member
Here's another example of black mesa. It affects smoke and fog effects really badly. I've had the same problem with other games. Happens in both SDR and HDR.

 

sykotik

Distinguished Member
Have you an other TV or monitor to test the PC on ?
could be the TV , or hardware issue in the PC
 

SnakePlissken006

Active Member
It only seems to be when running games as far as I know. You can even see slight banding in this load screen. As far as youtube videos and everything else on pc it looks fine. For comparison I watched a 4k video on YouTube playing dead space 2 on the same gpu as me on my pc and there was no banding or contrast issues.
 

Attachments

  • 20220330_192330.jpg
    20220330_192330.jpg
    211 KB · Views: 14

SnakePlissken006

Active Member
Another example. This is starting to get annoying now I've literally tried everything. Also contacted both Microsoft and nvidia but they're no help either. Maybe pcs just aren't compatible with 4k tvs?

 
Last edited:

sykotik

Distinguished Member
What hdmi cable are you using ?
The Hdmi cable needs to be a Certified 48Gbps to handle the bandwidth
I have Two PC's
One has the zeskit maya on one TV samsung 4k ( RTX 3080)

Amazon product

and the other is fibre optical hdmi 10m on a lg 4k TV (RTX 3080ti) and both work fine ( had to get this from the US at the time of needing it )

Amazon product


There loads of "48Gbps" cable on Amazon and i have tried most of them but only these two above have work for me.
The 2nd one is expensive, but's that's because of the length.
 

SnakePlissken006

Active Member
What hdmi cable are you using ?
The Hdmi cable needs to be a Certified 48Gbps to handle the bandwidth
I have Two PC's
One has the zeskit maya on one TV samsung 4k ( RTX 3080)

Amazon product

and the other is fibre optical hdmi 10m on a lg 4k TV (RTX 3080ti) and both work fine ( had to get this from the US at the time of needing it )

Amazon product


There loads of "48Gbps" cable on Amazon and i have tried most of them but only these two above have work for me.
The 2nd one is expensive, but's that's because of the length.

I'm using this. It should definitely be hdmi 2.1 as it allows 4k 120fps.

Amazon product
 

SnakePlissken006

Active Member
I'm starting to think my gpu might be faulty although nvidia are refusing to believe there's anything wrong with it. It is strange why a faulty gpu would only affect colours though.
 

sykotik

Distinguished Member
That was one of the cables that didn't work for me , yea it say's HDMI "2.1 4K 120" on the box , but it was finicky half the time i didn't get a picture ( or i would lose picture when starting a game (the division 2) and other half was the same problem as yours colour banding )

how far is the PC from the TV ?
I would suggest ordering the zeskit Maya from amazon and give it try, if it doesn't work send it back and get your money back,
then you'll know it's not the cable.
 

SnakePlissken006

Active Member
That's strange. All the comments an amazon say the cables hdmi 2.1 and cru recognises it as hdmi 2.1? It only seems to be in game as far as I know. I used the same cable for ps5 and had no issues.
 

sykotik

Distinguished Member
Not sure what else to say to try,
Only options left is to try the linux option above and use steam big picture

Or if possible try the gpu in an pc.
 

Delvey

Distinguished Member
Sorry I'm not interested in downloading Linux I need Windows.
If you are not interested in trying all possible solutions, why post?
Try a different software.
Try a different cable.
Try a different monitor/TV
Try Displayport
If after you have tried all of the above, and it still occurs, your GPU is probably faulty
 

The latest video from AVForums

Samsung S95B QD-OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel

Latest News

PSB Speakers unveils Passif 50 loudspeaker
  • By Ian Collen
  • Published
Samsung Gaming Hub goes live
  • By Ian Collen
  • Published
Huawei unveils FreeBuds Pro 2 true wireless earbuds
  • By Ian Collen
  • Published
Sony unveils Inzone gaming brand
  • By Ian Collen
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom