Chromecast Audio Enabling Full Dynamic Range Query

Witterings

Active Member
I only learnt about DAC's and what they do yesterday and I have 2 Chromecast Audios which I understand have DAC's built it.
I saw a post that says you have to enable full dynamic range which if in a device on google home is in settings at the top right hand side.

My Android tablet where I hadn't updated Google Home for ages had the settings option available but every time I tried to click on the setting button it it crashed the App (same with an Adroid phone).
I updated the App on the tablet and the settings for each device has disappeared and is no longer available, I haven't updated the phone and it's still there but just crashes the App evertime I click on the settings icon.

Does anyone know any other way I can enable full dynamic range .... almost seems like they're trying to force us away from Chromecast audios and wish I'd learnt about it ages ago and done it before they updated the App.
 

Jamie

Distinguished Member
Do you connect via analogue cable or use an optical cable?

The setting is only relevant if you use analogue. I've just checked and the option is still there in my Home app. I'm on Android and have version 2.48.1.9
 

Witterings

Active Member
Do you connect via analogue cable or use an optical cable?

The setting is only relevant if you use analogue. I've just checked and the option is still there in my Home app. I'm on Android and have version 2.48.1.9

Whatever you do don't update your version .... I spent ages on "chat" today with a Google Chromecast Rep and the were actually apalled it's been removed.

I tried side loading some older versions and they didn't work, ranged from what I was experiencing with my older version taht when you click on the settings button it just crashes and found some others that showed a blank screen as reported in some other forums.

I was digital cable, again I only found out yesterday it needs to be analogue cable but the options not there in google home to try it anyway ... although I will try and find / sideload the version you have.
 

Witterings

Active Member
Do you connect via analogue cable or use an optical cable?

The setting is only relevant if you use analogue. I've just checked and the option is still there in my Home app. I'm on Android and have version 2.48.1.9

Whilst you may be able to see it, have you tried actually clicking on the settings button to see what happens?
 

Jamie

Distinguished Member
Whilst you may be able to see it, have you tried actually clicking on the settings button to see what happens?
Yes, although 3 of my 4 CCAs are connected digitally I have managed to toggle the setting (and got what android calls a toast message appear at the bottom saying setting applied) on all of them.
 

Witterings

Active Member
Yes, although 3 of my 4 CCAs are connected digitally I have managed to toggle the setting (and got what android calls a toast message appear at the bottom saying setting applied) on all of them.

I think the weirdest part is having downloaded and installed the same version as yours, would have thought that'd work but thanks again.
 

Cebolla

Member
Really odd, I too have no such issues and that's both with the 24.48.1.9 and the latest 24.48.75.6 version (presumably your latest version - I got it from APKMirror, as the Play store was only giving me 24.48.1.9 as the latest) of the Google Home app.

Thought it best to be certain of what your actual issue is. Are you not able see and/or tap 'Audio' in the app's Chromecast Audio settings to go to the Audio settings' subsection (which should include the Full dynamic range setting)?

1645792886795.png


1645793036673.png



The older version of the Google Home app had all of its Chromecast Audio settings in one place, so much so that you had to swipe to get to the Full dynamic range setting, so I can see why Google reorganised it to tidy it up. For example, version 2.29.1.7 from APKMirror (which works for me without crashing, BTW):

1645793234193.png



Incidentally, what firmware version is the app showing your Chromecast Audio on - mine is on 1.56.281627 (I believe it's the latest).
 
Last edited:

Witterings

Active Member
Panic slightly over I've found an old Ipad Mini 2 and it works on there (but won't on my iphone), that said I'd still like to get it to work on my Android as that's what I use most.

I thought full dynamic range was something that had to be enabled but it's automatically showing as on if it's plugged into an analogue, one of the devices was plugged into a digital and it wasn't showing but as soon as I switched it over it showed up as on.

I've done a screenshot of my android below, the 3 dots offers you help or feedback and the sysmbol to the left bass & treble ... if I go to settings on the home page there's no option for audio either

1645798289278.png
 

Cebolla

Member
Wow, the Cog icon is missing - you won't be able to view most of the Chromecast Audio's settings & info, never mind set the Full dynamic range or find out what the firmware version is!

1645802364908.png



The only other difference I can see is that you haven't added your Chromecast Audio to a room, given that your pic is displaying the Add to a room button.
 
Last edited:

Jamie

Distinguished Member
As long as it's enabled on the CCA it shouldn't matter wether it can be accessed in. the home app, the bigger question is can the app(s) you want to use with it see the CCA and play music to it? You may find once it's playing it may even suddenly start to show the options on the Android device, I've certainly had intermittent instances of various settings on various devices not showing in the Home app from time to time.
 

Karm

Standard Member
Just checked mine and settings were missing, I added the device to a new room and the settings appeared, give it a try.
 

The latest video from AVForums

Paramount + UK launch: Halo, Star Trek and Beavis, and all the latest 4K + Movie/TV News
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom