• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Cease my madness forthwith: 2G iPod Touch and Internet Radio.

Flimber

Distinguished Member
Is there an app or apps, pray tell which can provide such a service ? I search but can fine none :(
 

mij

Well-known Member
Found this on google:

Here's a Google search which will find every app in the US iTunes store which is compatible with the iPod Touch 2G or iPhone 3G, and which includes the word "turtle". (You can replace "turtle" with any search term you want).
turtle site:itunes.apple.com/us "requires ios 4.2" OR "requires ios 4.1" OR "requires ios 4.0" OR "requires ios 3.2" OR "requires ios 3.1" OR "requires ios 3.0" OR " requires ios 2.2" OR "requires ios 2.1" OR "requires ios 2.0" - Google Search

Likewise, the following search will find apps in the US iTunes store which are compatible with the original iPhone or original iPod Touch, and which also include the word "turtle" (Again, change "turtle" to anything you want).
turtle site:itunes.apple.com/us "requires ios 3.1" OR "requires ios 3.0" OR " requires ios 2.2" OR "requires ios 2.1" OR "requires ios 2.0" - Google Search

Note that the results will include apps with specific hardware requirements, like the iPad or iPhone 3GS. Still, this will filter out 95% of apps which are incompatible with the desired iOS devices. I'm wary of adding search elements to filter out undesired hardware, because they might also remove desirable apps.

And this: to get a newer apps to work on your old device heres what you have to do.

1. locate an app in your filesystem, usually an itunes folder with all your apps.
2. rename the IPA to ZIP
3. open the zip folder, locate info.plist
4. open info.plist using a text editor, and in the description where it says minimum IOS change to the IOS of your old device.
for example if its MinimumIOS6.0 change it to MinimumIOS3.0

it works for almost any app, i just came across 2 or 3 out of about 200

Good luck.
 

submariner

Standard Member
Found this on google:

Here's a Google search which will find every app in the US iTunes store which is compatible with the iPod Touch 2G or iPhone 3G,

I created that post a couple of months back on a different forum, and have since refined and updated it. Here's the latest tool to search the iTunes store for apps compatible with iOS 4.2.1, iOS 3.1.3 and earlier on the older devices.

(Search for "radio" to get a very long list of compatible apps.)

https://sites.google.com/site/iossearch/

Hope you like it!
 
Last edited:

Flimber

Distinguished Member
The answer to the OP's troubles was "The Radio" for everyday usability and "OoTunes" for fancier stuff (inc. recording).

Mike.
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom