Can't make calls through my home phone with the Huawei B525 router

giltbrook

Member
I am having the same problem, using Three on a Huawei B525s-23a router, software 11.189.63.00.1217, Voicemail turned off at Three.
I can make calls but can't receive them, just getting the engaged tone, I have been through all the settings and it does seem to work if I set the router to 3g only but this gives me poor internet. When I was messing about with the settings it did work on an incoming call once on Auto, but when I tried it a second time, I just got the engaged tone. The problem seems to be that when an incoming call is successful, and when set to Auto, it doesn't disconnect when the call is finished, this is why the engaged tone is present, but I cannot find a way to force the disconnect from the router. I have tried turning the phone base unit off and on to see if that disconnects the call and it makes no difference, so it seems it must either be the router that is keeping the call open, or it is something at Three's end, anyone any ideas?
 
Last edited:

daneccles

Active Member
You appear to be missing "00" from the software version number, that apart it's the same as mine which works for calls in and out. You must have the router set to auto as it will default to 4g. "Auto" will allow it to switch to 3g for calls then switch back when you hang up. But if you can already make outgoing calls it would appear to be set correctly. If your router is connected to an answerphone incoming calls could be going to that. If so, turn it off. You may have to ask Three to disable voicemail.
I use a wireless phone that has a disconnect button, but putting a normal phone back in its cradle should do that anyway so I have no idea why yours doesn't.
My router is B525-23a. Maybe that's the relevant difference?
Alternatively you could do what I do, get a PAYG sim with a separate account with Three, stick it in a separate phone and have all your friends call that instead. They call my mobile number, I call out using the router with a DECT phone for free calls. A mobile phone is also much better than the router for texts and with 3 PAYG they're cheap. A £10 top up for it lasts me ages.
And another advantage of having two devices, if the B525 breaks, you can put the sim in your phone and set it to hotspot to give you temporary internet until the router is fixed or replaced.
 

GuyFingers

Standard Member
Hi, I have a similar problem in that I can't receive incoming calls (they divert to voicemail) but I can make outgoing calls. The dial tone I get is not BT standard but just a constant tone, however, if you ignore it and dial anyway, the call does connect - although it is much slower to connect so you do need to be patient. Worth trying before you flash anything! And if anyone has a solution to the incoming calls, I'm interested. It did work when I first tested it but only a couple of times. Now incoming calls go straight to VM.
Gilbert, you have to turn VM off for it to work properly. Might have to do this by speaking to the operator. I did it but I can't remember how
 

GuyFingers

Standard Member
My router is B525-23a. Maybe that's the relevant difference?
Mine too, and it works great
Like a previous poster said, try a few different phones/wires as they're not all wired the same.
I tried my old dect phone with no joy, then when I plugged my wife's panasonic in, it worked.
 
Last edited:

giltbrook

Member
Thanks for the reply, it was my fault the 00 was missing, I have corrected that now. No problem with the answerphone, and Voicemail turned off at 3's end. I have used this before with a 3 sim and it was OK, (after some teething problems), then I changed to Smarty for a year and that was OK, now back on 3 and the problem has occurred. I have got other means for incoming calls, and I originally had the Voicemail set to give out my other number to get around this problem., but I have cancelled Voicemail now to eliminate that. I have been playing some more with settings and I have had test incoming calls working a few times, but it soon disappears again. Is the correct APN three.co.uk? I had it set to 3internet with the Smarty sim, bu I have gone back to three.co.uk now.
 

giltbrook

Member
Sorry, my router is the B525s-23a, I don't know where I got the other number from. I have corrected the original. Are your routers just B525, without the 's' after?
 

daneccles

Active Member
I don't specify an apn, just set everything to auto and let the router find it. The fact that you can make outgoing calls means you are nearly there but it seems like voicemail is screwing it somehow.
 

giltbrook

Member
Thanks for all the replies, after trying numerous variations of system changes, I decided to go for a full system reset and it cured the problem, although I can't see any difference in the settings to what I had already tried. It did reset the APN to 3internet instead of three.co.uk but I had already tried that before.
Now set up with my Dect Answerphone giving out my main mobile number.
 

GuyFingers

Standard Member
Thanks for all the replies, after trying numerous variations of system changes, I decided to go for a full system reset and it cured the problem, although I can't see any difference in the settings to what I had already tried. It did reset the APN to 3internet instead of three.co.uk but I had already tried that before.
Now set up with my Dect Answerphone giving out my main mobile number.
Glad you got it sorted.
Ah the old adage, turn it on and off again
(And reset to factory settings of needed!)

Oh, btw, I'm having nightmares with Smarty at the moment as I can't access my Dropbox. Shame as I'm getting great 4G+ speeds. Hope they sort it soon as I've also taken a contract out with THREE and they've told me I can't get 4G+, even though it's the same mast and the same company!!!
 
Last edited:

daneccles

Active Member
I was getting pretty good speeds too until the lockdown. I thought at first it was a tree or something getting in the way of the tower so one night I checked at about 4am and it was flying, so it's obviously been congestion. Everyone around here seemed to be using their mobile phones to stream content for the last three months and hitting my download speeds. As people are now drifting back to work and school it's beginning to get better again.
 

giltbrook

Member
Well, the Huawei B525 factory reset lasted for one day before it reverted back to giving out the 'busy' tone again on incoming calls. No settings had been altered since the factory reset, I am just going to try another factory reset and see what else I can come up with.
Two more factory resets done, and it seems that my problem might be with the Panasonic KX-TGC220E Dect phone that I have. When I set it to 'Answerphone' and it receives an incoming call, after giving out the message and taking an incoming message, it does not drop the call, so the phone becomes permanently engaged, even if it is switched off. I will leave the Answerphone off for a few days to test it, then if OK, I will do a reset on the phone and see if that clears the problem.
 
Last edited:

giltbrook

Member
The problem with not accepting incoming calls due to the line being seen as busy seems to be reoccurring no matter what I try to do. The Huawei router has been reset to factory settings numerous times, and seems to be OK for a couple of hours before faulting again. I have reset the Panasonic phone back to factory settings and that has not cured anything, and I can't think it is happening at Three's end as every time the router is reset, it initially works OK.
 

Dog

Member
I have the same problem with Three on a B525 with a different software version. The router works perfectly with a Vodafone SIM.
 
Last edited:

giltbrook

Member
I am still having the same problem, I rang the number last night and the call got through, but when I rang it again this morning I got the busy tone again. If I leave it a couple of days, the occasional call will get through before resorting back to 'busy', so it seems it is definitely to do with the router, (or something else), not dropping the call after the call has ended.
It is good to read that it works perfectly with a Vodafone SIM, worth knowing if I ever need it as the main incoming line.
 

Dog

Member
I can't get it to work on Three with incoming calls even with factory resets. I think it used to work a few months ago but I can't be sure as I may have fully tested it on vodafone and then only tried a dial out on Three.

You have probably already discovered that you can switch Three call forwarding totally off with ##002#
and then individually reinstate when busy, when unanswered and when unreachable to 07782333123 (destination) using the codes in this link
GSM Feature Codes

I can confirm from using all the combinations that Three thinks the line is busy when the number is called and the router preferred network mode is set to either 4G only or Auto.
 
Last edited:

Similar threads

The latest video from AVForums

Podcast: New TVs, Samsung Q800T Soundbar review, IFA latest, Movie and AV News, B+W Brad Pitt

Trending threads

Top Bottom