Can't install anything with large files without corruption?

Bobbler

Banned
Help!
Since I put together my computer parts on the new board I bought here the other week I don't seem to be able to install any games at all anymore.
I first noted errors when trying to install Starcraft 2 on the newly built machine, despite using my original DVD, then my friends DVD then a copy of the Starcraft client from the Blizzard website it always fails at either 30% (when using the downloaded copy) or around 50% on the DVD.

I thought at first it was just one of those things, but now after rebuilding the machine again from scratch a total of four times, with different versions of Windows and on different hard disks, I think it's something more fundamental.

It appears to be corruption taking place when using a larger file size, smaller stuff seems to be unaffected by it - so I can install utils like Winrar or Firefox, but now seem to be narrowing it down to larger files - I attempted to re-download the SC2 client again and about 35% done it told me that the files are corrupted.
MW2 is doing the same thing, as is Battlefield Bad Company 2, COD WaW.

I have removed my 250GB primary hard disk and used one of my "data" disk drives (Samsung 1TB F1's) to install Windows on. This time I couldn't get past about 30% of the Windows 7 64 Bit installation, either from the original CD, my backup or by using a USB key with the files on required. The same thing happened when I RAID'd it too and started over with Windows XP. I managed to get my copy of Vista to eventually install from an external hard disk instead, but it still took a few tries.

I have tried the latest BIOS for the board and then a slightly older one - board is a Gigabyte GA-X38-DQ6 (ICH9R SATA).

I left it running over night two nights ago doing a full disk check (using Ultimate Boot CD 4 Windows rather than the OS on the machine) - no errors found at all.
Last night I left it running Memtest 86 overnight, no memory errors at al found either.
Since this morning it has been crunching on SuperPI and is doing just fine - it appears good and stable in regards to CPU, temps, memory.
Just started Barts StuffTest to see if anything shown up that way.

I was thinking driver issues at first but as the errors during the installation of Windows took place, this doesn't seem to be the cause as no special drivers where loaded save what the installer stuff uses itself.
I have tried the disk (when using a single) in both AHCI and IDE modes and varied the SATA connections too.

I am at a loss having not encountered something like this before, it really has me beat but wonder if I am just missing something like a BIOS setting or similar "oversight" on my part.


Sorry just realised I forget the rest of the machine specs in case it's of importance:
Core2Duo E4500 at Stock 2.2GHZ
Geforce GT240
2x 1TB Samsung F1 SATA disks (currently in RAID0 -set in bios)
2x 1GB Corsair XMS2 DDR2 667
2x 1GB Corsair Dominator DDR2 1066
 
Last edited:

next010

Distinguished Member
It sounds like classic memory/ram corruption to me though the clean memtest+ is strange.

Mixing RAM isn't a particularly good idea either even if it comes from the same maker the actual chips may not be and come from different factory's and have different timings.

Remove the XMS2 or Dominator RAM, leave the RAM timings set to SPD in the bios and see if that makes any difference.
 

Bobbler

Banned
Cheers Next010. Will give that a bash in a second.
I know what you mean with regards to the RAM, was my first thoughts too hence the Memtest runs overnight.

EDIT:
Well, I am 100% installed and patched now that I have dropped the 2GB of XMS2, though this still doesn't make a great deal of sense to me, as the XMS2 RAM was what was in the computer originally on my old board and has been working for about 2 or 3 years fine.

Better keep an eye out for 2 more GB of Dominator RAM now :(
 
Last edited:

next010

Distinguished Member
It's possible there is nothing wrong with the RAM rather mixing the two different kinds of RAM was causing the fault. The automatic timings read from SPD dont always work out and I've seen SPD corruption by mixing different RAM modules before.
 

Bobbler

Banned
Looks to be something along those lines, memtest on both sets on their own reveals nothing wrong. I have managed to snag a pair of matching Corsair Dominators so will bang the others up for sale I guess to offset it.
 
Top Bottom