Can't get sound from LG TV to Onkyo receiver--please help!

Scrop

Novice Member
Hi. I'd had an LG OLED65B6V TV working with an Onkyo TX-NR555 receiver just fine (more or less) for years. When I clicked the TV button on the remote, the sound from the TV would then go to the Onkyo and out the attached speakers. Recently I've had to reset both the TV and the receiver and change some wiring due to an unrelated issue, and since then I haven't been able to get the sound of the TV through the external speakers. I've made sure the HDMI cable is connected from the ARC input port of the TV to the ARC output port of the receiver. I've set the Sound Out setting on the TV to Audio Out (Line Out). I've set the HDMI CEC to On and the Audio Return Channel to Auto on the receiver. Could someone please tell me what to do next? Is there a particular channel I need to assign the HDMI Input to on the receiver? (I've tried them all.) I imagine there's some very simple mistake I've made or something that needs to be done that I've overlooked, so apologies for my denseness in advance. Any ideas would be greatly appreciated. Thanks!
 

two2midnight

Distinguished Member
Hi. I'd had an LG OLED65B6V TV working with an Onkyo TX-NR555 receiver just fine (more or less) for years. When I clicked the TV button on the remote, the sound from the TV would then go to the Onkyo and out the attached speakers. Recently I've had to reset both the TV and the receiver and change some wiring due to an unrelated issue, and since then I haven't been able to get the sound of the TV through the external speakers. I've made sure the HDMI cable is connected from the ARC input port of the TV to the ARC output port of the receiver. I've set the Sound Out setting on the TV to Audio Out (Line Out). I've set the HDMI CEC to On and the Audio Return Channel to Auto on the receiver. Could someone please tell me what to do next? Is there a particular channel I need to assign the HDMI Input to on the receiver? (I've tried them all.) I imagine there's some very simple mistake I've made or something that needs to be done that I've overlooked, so apologies for my denseness in advance. Any ideas would be greatly appreciated. Thanks!
Check that you have HDMI CEC on in the Onkyo. It needs to be on in both TV and receiver as it takes two to tango...;)
 

The latest video from AVForums

Samsung S95B QD-OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom