• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Can't get multi-channel audio from DVD-3910


Standard Member
I just bought a 2nd hand Denon DVD-3910 (European model). It seems in great condition and has a manual, which I've read back and forth many times now.

I bought it mostly for hi-resolution stereo audio. Today I wanted to test that the back channels worked - just for fun at the moment. When I play SACD or DVD-A discs with multichannel audio I see the 5.1 indicator lights are activated on the front panel. However when I connect audio cables from the SR and SL outputs on the back to my stereo amp - I hear nothing. Total silence. I do however hear down-mixed stereo sound out of FR and FL. (That is, it sounds identical to the dedicated 2-channel output created by the player's D.Mix function)

This can't be right? :lease:

While I hopefully have a 3910 expert here, how do I access the Audio multichannel set-up menu in the DVD-3910 menu? It's always greyed out in the OSD, even without a disc in the player.


Active Member
Gosh, I'm not at home right now.. but have downloaded the 3910 manual.. I still have a 3910 at home connected via Denon link just for SACD... it's a great player..

Anyway.. here's what I think you might try..

In the Audio Setup is does it show the Audio Channel option as 'multi channel'? rather than 2CH ?? It obviously needs to be 'multichannel'

If it shows 'multi channel' move the cursor over to that option and press enter, you should then be taken to the speaker configuration, channel level, and delay time menus.. Make sure you have something sensible for these values..

In 'others' it might help to set the player mode to Audio, and using the front panel button ( or on the remote ) set the SACD setup mode to multi.

You might also try setting the IEEE and Denon link to off in the digital interface set up..

To cut a long story short.. change as many settings to the factory default as possible.. and I'm sure you'll get there. :)


Standard Member
Thanks for the input!

In the Audio channel option of setup it does show multichannel - but it's greyed out. I can't select it or change it. This means I can't access speaker configuration, channel level etc.

In "others" it's in Audio mode. (I have tried it in Video mode but this made no difference).

For SACD setup I have tried all the settinsg and it makes no audible difference to the output. All I get is stereo (though I don't know if I'm hearing the SACD or CD layer).

IEEE and Denon Link are turned off in the menu and nothing is connected to those outputs.

I can add that the firmware is 6609-B, which I think is one of the more recent versions. I can't access the European firmware on-line service, as seems to be the case for most people on this forum. As a 2nd hand unit I don't have a Denon dealer to contact - at least not without getting into expense I don't want. Returning the unit to the 2nd hand dealer is looking more likely I'm afraid, which would be a shame given how good this unit is in stereo.


Standard Member
Here you go ... see the notes at the top of page 17 in the manual...

The top of page 17 in my manual talks about language setup... But this was the clue I needed to fix this!

The solution: Under HDMI Audio Setup this was set to "Multi(Normal)". I thought that sounded "normal", but of course you can't get out both digital and analogue surround on these units at the same time. The wrinkle I didn't mention is that I'm not using HDMI, I'm using DVI.
Anyway - turned the HDMI Audio to 2CH (which I now read is the factory default) and bingo, now I can access the multichannel audio menu. I bet this also turns on the analogue multi outputs on the back. [EDIT: It did]

Last edited:

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom