Can't get a picture from Sony VTX-S750U Digibox to TV

Discussion in 'Satellite TV, Sky TV & FreeSat' started by LanceOC, Jan 25, 2008.

  1. LanceOC

    LanceOC
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Probably missing something here and could do with someones help.

    Old skybox malfunctioned. a kind friend, donated, a second Hand Sony VTX-S750U. Made connections in normal way, via Yamaha AV amp (nothing special but works). Digibox signal is fine as sound is being received which plays through amp but no picture to the TV.

    Checked cables to TV by connecting a DVD player, that is fine.

    Replaced the Digibox with a second hand purchase (same brand and model) from Ebay and exactly the same issue... sound but no picture.

    Am I missing something. Do I need to setup by pressing a combinations of buttons??

    Confused. Any help would be appreciated.
     
  2. Andy98765

    Andy98765
    Well-known Member

    Joined:
    Feb 15, 2006
    Messages:
    10,472
    Products Owned:
    2
    Products Wanted:
    0
    Trophy Points:
    133
    Ratings:
    +1,365
    Are you sending video via the AV amp? If you are then change and connect via SCART directly to TV.
     
  3. LanceOC

    LanceOC
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    will try, thanks, good advice but I have already tried connecting through the amp to the DVD player which worked fine..
     
  4. Andy98765

    Andy98765
    Well-known Member

    Joined:
    Feb 15, 2006
    Messages:
    10,472
    Products Owned:
    2
    Products Wanted:
    0
    Trophy Points:
    133
    Ratings:
    +1,365
    I think to make things simple you need to explain what make model AV amp you have What type of Scart cables you are using between the STB and AV amp, i.e. is Scart to three phonos etc, if so this will not work as the STB would by default output in RGB rather than composite.
    If you have not run out of Scart sockets on the TV then DO NOT take your video sources via the AV amp.
    Check ALL your sources are directly connected to the TV via RGB enabled Scart sockets and then check the sources (STB/DVD) are set to 16:9 not 4:3 assuming you have widescreen and are outputting in RGB not Composite.
     

Share This Page

Loading...