Can't connect to internet (DNS issue?)

ocelot20

Active Member
Hello,

Ok so this is a problem I have never had before. Yesterday morning we had a power outage. Which lasted about 5 minutes. Ever since the power come back on I can't connect to the internet at all. Wifi or wired. My phone or tablet or my PC's can not connect to the internet.

Now here is the strange part. My PS4 and PlayStation TV can connect to the internet with no issues. But bear in mind my PS4 and PS TV have a static IP each.

The main PC is connected via wire into the router. My other PC is connected to the router via powerline adaptor. My ISP is Virgin Media and the router is a Superhub 2ac.

When I try a troubleshoot on the main PC. It says the connection between access point, router, cable modem and the internet is broken. When I try a troubleshoot between my other PC (connected via powerline) it says there is a DNS error.

So far I have tried turning off all devices including the superhub. Turning everything back on 1 by 1. Flushing the IP and renewing the IP on both computers. I have even tried factory resetting the router to default settings. This did not work. When I log into the router it says my PC's are connected to it. I can connect my phone and tablet to the router via wifi no issues. But I get no internet access from them.

I am at a loss. Any other suggestions I can try? I do have a Virgin Media Engineer coming out tomorrow afternoon. But if I can get it fixed my self before then that would be ideal.

Thanks.
 

MacrosTheBlack

Well-known Member
DNS error is easy to check on the PC. Just edit your ip settings and specify manual dns addresses. Use googles, nice and easy to put in:
Primary DNS: 8.8.8.8
Secondary DNS: 8.8.4.4

Also from the PC can you ping your router (the superhub). From a CMD prompt type: ping 192.168.0.1 (assuming that's your routers ip address at the moment?
 

ocelot20

Active Member
DNS error is easy to check on the PC. Just edit your ip settings and specify manual dns addresses. Use googles, nice and easy to put in:
Primary DNS: 8.8.8.8
Secondary DNS: 8.8.4.4

Also from the PC can you ping your router (the superhub). From a CMD prompt type: ping 192.168.0.1 (assuming that's your routers ip address at the moment?
Thanks for the reply. Ok so the pc (one with powerline) is now connected to the internet. If I turn the PC of and on then I can't connect again. However if I keep disabling the network adapter and re-enabling it will work again. I tried to do the same with the main PC but that still won't connect.

I ping the router IP like you said and this is what I got.

Microsoft Windows [Version 10.0.10240]
(c) 2015 Microsoft Corporation. All rights reserved.


C:\Users\My-PC>ping 192.168.0.1

Pinging 192.168.0.1 with 32 bytes of data:
Reply from 192.168.0.1: bytes=32 time=10ms TTL=64
Reply from 192.168.0.1: bytes=32 time=3ms TTL=64
Reply from 192.168.0.1: bytes=32 time=3ms TTL=64
Reply from 192.168.0.1: bytes=32 time=3ms TTL=64

Ping statistics for 192.168.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 3ms, Maximum = 10ms, Average = 4ms

C:\Users\My-PC>
 

ocelot20

Active Member
UPDATE:

Again thanks Marcos for the help. I shut down the PC that I managed to connect to the internet. Upon restart it again would not connect. So I did what you suggest and manually gave the PC a IP address and DNS. It worked right away.

So I did the same for the main PC and again it worked right away. So at the very least I got both PC's back up and running at the moment. However I still can't get my phone or tablet to connect to the internet.

I suppose I can always give them a manual IP address as well? But I rather it all just be automatic to be fair. So it seems the router is having a hard time assigning IP addresses devices?
 

MacrosTheBlack

Well-known Member
So you have connectivity to the router. Try the DNS settings I suggested and seeing if you can then get online.
 

MacrosTheBlack

Well-known Member
Ok then so if static ip addresses work, it sounds like it's handing out a bad DHCP address (auto assigned) to wired and wireless clients. Can you change a PC back to DHCP so it's automatically assigned an address and then post up the results from command prompt of: ipconfig /all
 

ocelot20

Active Member
Ok then so if static ip addresses work, it sounds like it's handing out a bad DHCP address (auto assigned) to wired and wireless clients. Can you change a PC back to DHCP so it's automatically assigned an address and then post up the results from command prompt of: ipconfig /all
What do you mean by change a PC back to a DHCP? Do you mean just select Obtain a IP address automatically and Obtain a DNS server address automatically?
 

MacrosTheBlack

Well-known Member
Yep. Then open a cmd prompt and type in: ipconfig /all

Then paste up the result and hopefully should be able to see what the issue is.
 

ocelot20

Active Member
Microsoft Windows [Version 10.0.10240]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Main-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Ethernet
Physical Address. . . . . . . . . : 84-2B-2B-AC-97-1E
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::d946:90af:890d:5abb%5(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.106(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Thursday, November 5, 2015 5:23:59 PM
Lease Expires . . . . . . . . . . : Thursday, November 5, 2015 5:26:29 PM
Default Gateway . . . . . . . . . : 192.168.0.14
DHCP Server . . . . . . . . . . . : 192.168.0.14
DHCPv6 IAID . . . . . . . . . . . : 226765611
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-C7-E1-E5-84-2B-2B-AC-97-1E
DNS Servers . . . . . . . . . . . : 192.168.0.14
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{389EB61B-2410-4B5B-A743-DF0519A1B5BB}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

C:\WINDOWS\system32>
 

MacrosTheBlack

Well-known Member
Hmmmm..... Ok so why have you changed the Superhub's ip address to 14, as in 192.168.0.14?

Normally you'd have it at either end of the range of device addresses (1 - 254). So 192.168.0.1 or 192.168.0.254

Do you have any other devices on your network with a manual ip address of 14? As that could well be the issue.
 

ocelot20

Active Member
I have not changed it to 14. Only things that I assigned to a static IP was my PS4 which was on .10. My PS TV which is on 0.7 and my XB1 which was on 0.5

I logged into the router and I checked the connection on everything that is connected to the router none of them are .14.

I also looked in the DHCP settings and this is what it says.

LAN IP
IP Address 192.168.0.1
Subnet Mask 255.255.255.0
DHCP
Check to enable or uncheck to disable DHCP
IP Address 192.168.0.2 to 254
Max Users
Lease Time 1 Day
 

MacrosTheBlack

Well-known Member
Ahhh yes of course you pinged the router earlier at the expected address of 192.168.0.1 when you manually assigned the ip address.

Ok then. Answer must be you have another device handing out DHCP ip addresses on your network. That device has an ip address of 192.168.0.14. It's overriding the DHCP from the Superhub router.
 

ocelot20

Active Member
I do have a mini router upstairs. I use it as a wifi extender for when ever I use my tablet or phone upstairs. You think this may be the problem?
 

MacrosTheBlack

Well-known Member
Yep that's probably it. Turn it off and on the pc from cmd prompt type: ipconfig /release
then type: ipconfig /renew
Then do the: ipconfig /all
You should see all the 192.168.0.14 addresses from earlier change to point to the superhub instead at 192.168.0.1 and be able to get out on the internet.

Powering off and on any other devices will also get them online. You need to reset up your wifi extender so it's not in charge of DHCP. Leave that to the superhub.
 

ocelot20

Active Member
Thanks for the help. Powered off the mini router. Tried my phone and tablet and are now getting internet again :clap:.

Thanks again.
 

The latest video from AVForums

Podcast: CES 2021 Special - Sony, LG, Panasonic, Samsung, TCL and Hisense TV news and more...
Top Bottom