Can't change regions on a Sony BPD-S5500

Bertaut

Standard Member
A few years back, I purchased a multi-region Blu-Ray player, the BDP-S5500. Never had a day's trouble with it; everything worked fine.

Until today.

Long story short, it's locked on Region A and I can't change regions. I changed from B to A about a month ago and everything was fine and I've changed many times over the years with no issue. And now all of a sudden, pressing the blue button for region b does nothing (nor does the red for region c). I've tried a factory reset, checked to see if the firmware was up to date, and everything seems fine (I've made sure quick launch is turned off). I've also had a look around online and nobody else seems to have had this problem.

Any help would be immensely appreciated.

Thanks.
 

LV426

Administrator
Staff member
Can you tell by other means (eg use in an app or epg or text etc - or by an indicator on the machine that signals receipt of a remote command) whether the quoted/required remote buttons are actually working at all?
 

Bertaut

Standard Member
Thanks for the reply. Yeah, it occurred to me the problem might be with the remote, but I checked and the colour buttons are all working fine when I use them during text entry.
 

LV426

Administrator
Staff member
In that case I have nothing I can add - except perhaps to revert to the supplier for help. Or buy a new one!
 

Clem_Dye

Distinguished Member
Another remote might be worth a try. The buttons could be a bit 'marginal' if they've been used a lot. That said, perhaps there's a limit on how many times the region can be changed ...
 

The latest video from AVForums

Maverick UK Premiere IMAX Review + Top Gun, Tom Cruise, Tony Scott and 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom