Can't Add MS Points!!!

Emale1999

Standard Member
Hi

I've been trying for over a week now to add MS Points but keep getting the same error message and code (Can't retrieve information from Xbox Live. Please try again later). I contacted Xbox Support and after trying to fob me off at first by saying they were having problems 'at the moment' upon which I said its been happening for over a week they suggested that it might be the NAT setting (which was on Moderate) that was to blame. Off I went and changed a setting on my router which I'd been using on the previous setting without any problems from day one (9 months ago) and found it changed the NAT setting to Open, tried adding Points still got the same error. Next I tried adding a new payment method, still no luck, and finally I tried deleting Marketplace Data then rebooting....guess what....I still got the same error. I'm at my wits end, nobody seems to be able to offer a solution, can anyone help???!!!!


Thanks
 

lovelldr

Active Member
try going to the ms xbox website and adding your points to your account through there, making sure you enter everything properly. It's easier when typing through a keyboard...
 

lovelldr

Active Member
I have no idea, sorry. Haven't tried adding points myself. Hopefully someone here knows! I did have probs signing up to live though, where it wouldn't let me. Had similar message. Then after a while it worked?! Nothing changed...
 

Baz80

Active Member
Did that myself a couple of days ago turned out my credit card had expired so make sure your dates are correct and try again
 

The latest video from AVForums

Podcast: Samsung HW-Q800A Soundbar & Rotel Michi X3 Reviews + TV show and Movie News & Reviews
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom