Can't access Xbox Live from new ASUS RTAX56U router

Jazce

Active Member
I bought a new ASUS RT-AX56U router to replace my dying Netgear R7000. I'm with Hyperoptic and all I need to do is plug in the router and start adding all my devices back to my SSID's.

I added my Xbox One X to my 5ghz SSID, however it can't access Xbox Live. It shows as connected in the Router Web View (well it was, but when I check the app and the website it is showing nothing is connected). Hmm so something more is going on there even though I'm writing this whilst connected.


I tried changing the NAT type from Symmetric to FullCone but that still doesn't allow the Xbox to connect to Xbox Live. I'm starting to suspect this isn't a very good router and I might have to return it for another NetGear...

Has anyone got one of these, are you having issues connecting to xbox live, did you solve them? any tips?
 

ChuckMountain

Distinguished Member
The usual issue with changing routers is that the new one might come with a different default IP address range. The Internet Protocol (IP) address is the "number" that allows devices to talk to each other on a network. Akin to a phone number (apologies if you already know this) if you don't have one or it has the wrong area code then it won't work and connect to the Internet correctly. Different routers might have different private IP ranges i.e. different area codes and so the client devices need to be aware of this and refresh accordingly.

Normally this is cured by changing the wireless network and\or rebooting the device in question. You didn't ever set a manual\static IP address did you on the Xbox. If you did then this would need to be reset and recommend use the DHCP option if not already there.

Otherwise try disconnecting and reconnecting to the wireless network (your old router is not still on is it?) Thought the xbox had troubleshooting section too which are normally quite good for issues of this sort.
 

Jazce

Active Member
The usual issue with changing routers is that the new one might come with a different default IP address range. The Internet Protocol (IP) address is the "number" that allows devices to talk to each other on a network. Akin to a phone number (apologies if you already know this) if you don't have one or it has the wrong area code then it won't work and connect to the Internet correctly. Different routers might have different private IP ranges i.e. different area codes and so the client devices need to be aware of this and refresh accordingly.

Normally this is cured by changing the wireless network and\or rebooting the device in question. You didn't ever set a manual\static IP address did you on the Xbox. If you did then this would need to be reset and recommend use the DHCP option if not already there.

Otherwise try disconnecting and reconnecting to the wireless network (your old router is not still on is it?) Thought the xbox had troubleshooting section too which are normally quite good for issues of this sort.
Old router has been disconnected and essentially thrown out. I never set a static address for the Xbox, so that won't be it. I've disconnected and reconnected the xbox from this new router countless times and gone through the network help part on the xbox dashboard, but to no avail. Weirdly it can download Xbox firmware updates, but as soon as it gets to the dashboard, it claims it can't get an IP address or connect to xbox live.
 

ChuckMountain

Distinguished Member
Assume you have rebooted the router?

Are all other devices working correctly and do you have any custom DNS settings on your router? What is it trying to use?
 

Jazce

Active Member
Assume you have rebooted the router?

Are all other devices working correctly and do you have any custom DNS settings on your router? What is it trying to use?


No custom DNS settings, the screenshot below shows the WAN settings for the router.

1629550268230.png



On the NAT passthrough tab, only PPPoE is disabled (which i think is default, i don't remember disabling it).

And as you can see, it does appear to be attached to the network:

1629550661492.png
 

oneman

Well-known Member
How might I tell if I have a double NAT? I don't have a second Xbox.
Do you have routers working in series, like o e from hyperoptic router and the Asus. Also do you get this problem when connected with cable instead of WiFi ?
 

next010

Distinguished Member
You could try manual port forwarding.
  • turn it on in wan
  • select add profile
  • from famous game list pick xbox live.
  • internal IP address = pick xbox from list

To stop the xbox changing IP
  • go to lan dhcp server and enable manual assignment
  • under client name mac address pick xbox from list then click on add.

If that doesnt work there it might require more site here lists all ports used by xbox live.
 

MarkyPancake

Distinguished Member
I can't think what the problem might be at the moment. I've used ASUS routers for many years and they've always worked with Xbox Live and Sony PSN (an N66U, AC68U, AC86U).

ASUS firmware is compatible with Xbox Live, both via UPnP and manual Port Forwarding, and can report an Open NAT with Symmetric or Fullcone NAT (I use Fullcone on my AC86U, as there are multiple consoles in the house, usually connected to Live and PSN at the same time).
 

Jazce

Active Member
Cheers for all the help so far everyone.

Do you have routers working in series, like o e from hyperoptic router and the Asus. Also do you get this problem when connected with cable instead of WiFi ?
I don't have a series of routers; the ASUS is directly plugged in to the hyperoptic WAN cable and the ASUS is the only router providing wifi. cable from wall -> ASUS -> wifi -> xbox

I think the next step is to try:

You could try manual port forwarding.
  • turn it on in wan
  • select add profile
  • from famous game list pick xbox live.
  • internal IP address = pick xbox from list

To stop the xbox changing IP
  • go to lan dhcp server and enable manual assignment
  • under client name mac address pick xbox from list then click on add.

If that doesnt work there it might require more site here lists all ports used by xbox live.

Then if that doesn't work, try and find a long enough cable to plug in and see what's happening.
 

psychopomp1

Member
OP, have you tried a factory reset on the router and reconfigured everything from scratch? If not, I strongly suggest you do that first and see how you get on.

From my own experience, new Asus models tend to be buggy as hell and often a factory reset - which clears the NVRAM - fixes things.
 

jimscreechy

Active Member
I'm not sure what options you have under "Wan connection type" drop down list - can you tell us.

At any rate all the radio buttons which are currently sent to no, should be set to yes.
 

MarkyPancake

Distinguished Member
Cheers for all the help so far everyone.


I don't have a series of routers; the ASUS is directly plugged in to the hyperoptic WAN cable and the ASUS is the only router providing wifi. cable from wall -> ASUS -> wifi -> xbox

Interesting. So there's no modem between the Hyperoptic wall outlet and ASUS router.

I wonder if this is the issue and you need a DSL router instead. You would have to check with Hyperoptic about this.
 

psychopomp1

Member
Interesting. So there's no modem between the Hyperoptic wall outlet and ASUS router.

I wonder if this is the issue and you need a DSL router instead. You would have to check with Hyperoptic about this.
Hyperoptic provide only full fibre FTTP services therefore no DSL modem/router is required.
 

MarkyPancake

Distinguished Member
So the Hyperoptic cable should be providing a public WAN address to the router, which you can see in the router's WAN settings, then the router should be providing internal IPs to devices connected to it.

I wonder if something isn't set up correctly in the router's WAN settings for this type of broadband connection.
 

Jazce

Active Member
I'm not sure what options you have under "Wan connection type" drop down list - can you tell us.

At any rate all the radio buttons which are currently sent to no, should be set to yes.
So under the dropdown I have:

  • Automatic IP (current setting)
  • Static IP (I don't currently pay for the optional static IP and never have)
  • PPPoE
  • PPTP
  • L2TP
  • V6Plus
Which radio buttons set to no should be yes? The screenshot i shared had everything set to yes?

OP, have you tried a factory reset on the router and reconfigured everything from scratch? If not, I strongly suggest you do that first and see how you get on.

From my own experience, new Asus models tend to be buggy as hell and often a factory reset - which clears the NVRAM - fixes things.
I am very much considering a factory reset and adding the Xbox as the first client too. I'm going to give the manual port forwarding a go first and see how that goes. Though i didn't have to do this with my R7000
 

MarkyPancake

Distinguished Member
The ASUS firmware's UPnP implementation is capable of handling the ports needed for Xbox Live and an Open NAT for online gaming, so I would be surprised if it behaves any different with manual port forwarding.

Once you go down the port forwarding rabbit hole, in addition to the ports Xbox Live needs, you may also need to include ports for specific games for them to run correctly. Then there's the issue that port forwarding only works for a single device at a time, so if you have more than one console and try to play online at the same time, one will use the ports and the other won't be able to. UPnP avoids all this.
 

Jazce

Active Member
Just to close off this thread, I did a factory reset and now the Xbox is working!

Annoying that i didn't get to the bottom of the issue with my settings as they were, but at least I can now download all my warzone updates.

Thanks for the help eveyone!
 

MarkyPancake

Distinguished Member
DSL router like Asus RT is exactly what you need for FTTP and VM.
VM's DOCSIS based broadband uses a modem, which is what their supplied Super Hub does, so when you switch the hub to modem mode to use your own router, you don't need a DSL router.
 

oneman

Well-known Member
VM's DOCSIS based broadband uses a modem, which is what their supplied Super Hub does, so when you switch the hub to modem mode to use your own router, you don't need a DSL router.
I was thinking of something else but RT range is fine for VM and FTTP
 

The latest video from AVForums

Podcast: Panasonic JZ2000 Final Thoughts - TV Calibration: Should you? And More...
Subscribe to our YouTube channel

Latest News

What's new on UK streaming services for December 2021
  • By Andy Bassett
  • Published
Best Projectors of 2021 - Editor's Choice Awards
  • By Steve Withers
  • Published
Black Friday 2021: What you need to know
  • By Andy Bassett
  • Published
What's new on Blu-ray Special - The Cinema of Zhang Yimou & Gong Li
  • By Mark Costello
  • Published
AVForums Podcast: 24th November 2021
  • By Phil Hinton
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom