Can't access Game, Gamestation or Gameplay sites

tazmago

Well-known Member
Hi,

the last couple of days I have been unable to access 3 specific sites, these being Game.co.uk, Gamestation.co.uk and Gameplay.co.uk.

Everything else works fine, and I haven't seen any reports of these website being down. I am currently with Demon Broadband which I rarely have any problems with.

Does anyone have any ideas as to why this is happening? Are there any other Demon users experiencing the same problem?

I have already contacted Demon to ask about any problems at their end but have yet to hear anything.

Any help would be much appreciated,

cheers, Jason
 

accyuklad

Banned
try changing your dns

use opendns see if that fixes it

but if you go online gaming make sure to remove the opendns or you will get lag
 

tazmago

Well-known Member
Thanks for the reply. I have just had a response from my ISP and they have had a few complaints about this and their engineers are looking into it, so it looks as though its a problem at my ISP's end.

Hopefully it gets sorted out soon.
 

freestyle

Standard Member
have you heard any more on this?

its getting stupid now and their website isnt showing any report of the problem
 

Up2nogood_316

Standard Member
I have this problem too. Its quite a relief to find out that its nothing to do with something going wrong on my PC. What a joke, if I was GAME, etc I'd be pretty annoyed to think potential customers are being blocked due to some stupid ISP issue. Wow..
 

tazmago

Well-known Member
Hi, I spoke to Demon again yesterday (via text chat) and they said it was something to do with latency issues (whatever they are) and that they are still working on it. However, I have just had a look at the service status page and there is now a green light next to the routing/network part, but I still can't access those 3 sites.

I will give them until tomorrow to get it sorted and then complain again. It's getting a bit silly now :mad:
 

Up2nogood_316

Standard Member
Ha.. I'm on Demon too. They are awful aren't they lol I find ringing up the 'THUS' organisation directly helped get things moving when I was having speed problems before.. I actually complained to something like an IP version of OFCOM after being advised by someone to do so a few years ago, ended up having Demon ringing ME in order to sort things.. They must have been given a huge kick in the backside.......
 

tazmago

Well-known Member
OK, just as an update to this, I have just been in touch with Demon again, and they said that they have fixed it. I said that my experiences suggest otherwise and the tech guy have me do loads of ping tests, and came to the conclusion that the latency issues with these sites have re-occured. As a result it has been reported to their engineers again who will hopefully provide a more stable fix this time.
 

Up2nogood_316

Standard Member
As of right now the problem has not been fixed as far as I can tell. I feel like ringing them up myself and complaining in order to get some form of money back, this is an absolute disgrace. Pathetic.:thumbsdow
 

Up2nogood_316

Standard Member
Yea its quite a lot of messing about to change ISP though it takes time.. But you are right. I cant believe that its STILL not working. They are a bloody disgrace and are totally unprofessional. When I ring up for my MAC:code I will let them know just how crap they are ;) lol
 

freestyle

Standard Member
Still not working here, this is a joke now.

Funny thing is we use demon at work and that seems fine! So doesnt seem to affect all customers.
 

tazmago

Well-known Member
I DON'T BELIEVE IT! /Victor Meldrew impression

Demon have actually got the sites working again, only taken them 2 weeks.
 

The latest video from AVForums

Podcast: The Best TVs and Projectors of 2020, plus AV, TV Show & Movie News & Reviews
Top Bottom