Cannot get menu up on Cyclone Micro HD HDMI multi media player adaptor help

jnielow

Standard Member
Dear All,

I have just bought one of the above, I connected it the other night through HDMI cable followed instructions and the main menu fired up ok. I have since tried to use it again and all I get is a blank screen(no menu). I have gone into tv selected HDMI channel the tv then shows HDMI then this icon disappears goes to L+R checking speakers? then blank screen no menu.

I have attached it via AV composite and it fires up ok. I am not sure if I need to adjust TV/or media adapter.I do not want to adjust stuff that I am not familiar with. The media adapter is attached to an LG 32"LT75 TV.

On another point I have alot of AVI films are these going to be greatly enhanced by playing these through HDMI or is AV composite just as good as the original film/films were not downloaded in hdmi in the first place?

I hope you can help me!

Thanks

Jason
 

AVNick

Standard Member
It doesn't switch automatically between composite and hdmi output - you need to keep pressing TV System until you get the picture - there are several resolutions to choose from so keep pressing until you get the one you want. If the screen goes blank again, then you've gone through all the HDMI choices and back round to composite, so just try again.

HDMI gives you a much crisper picture regardless of the original source as it doesn't need to do any additional conversion between analog and digital.
 

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...
Top Bottom