1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can someone help me with setup of Rel Q150e and Pioneer VSX2014i please?

Discussion in 'Subwoofers' started by TarPot, Jun 15, 2005.

  1. TarPot

    Well-known Member

    Dec 16, 2002
    Products Owned:
    Products Wanted:
    Trophy Points:
    Hi all.

    I'm a subwoofer noob and would very much appreciate your kind help.

    My set-up I guess is a bit of a mish mash, but I like the sound it makes.
    I have a Pioneer VSX2014i amp, fronts-Mission 733s, rears-Mission 773s and centre-Kef 100 reference series.
    I've just got a good deal on a Rel Q150e and greatly need some advice on set-up.
    Rel recommend using both the neutrik cable and the phono cable, where Pionner say just use phono. From reading other posts I understand (I think) that Rel's method is better. So as not to lose bass in direct mode.
    The amp does auto MCACC set-up. What do I need to set my sub levels at? Because I guess if you have the sub turned up, the amp will compensate on auto set-up and turn it's levels down?
    Could any one give me a rough idea as a starting poing where to set my levels-Low, Hi, Rolloff, Mode?
    The default crossover on the amp is set to 80hz would that be ok for my system?
    I know that this kind of thing is down to the individual's taste, but if anyone could offer me any help as a starting point I would be very grateful.

Share This Page