• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Can my (old) Android boxes still run Kodi?

Looney14

Active Member
Hi all

I have 2 Android boxes from circa 2015-16.

One is a MX box - with android version 4.2.2.
Second is a K5 box - with android version 4.4.2

Both were bought off ebay - pre installed with stuff and worked fine. but as i've been away from UK they've not really been "maintained" as such and i need some help!

MOBDRO works on both still - so that was a pleasant surprise.

Kodi is the other thing I would like on them - used to use something called exodus BUT that does not work anymore now.

are the versions of my android box able to handle/install kodi? 4.2.2 and 4.4.2
KODI is now on v18 i think.

any advice is appreciated please :)
 

bubblegum57

Well-known Member
Kodi v17 and later requires Android 5.0 or higher

FReaktab has a version of Kodi that works on earlier android versions

FTMC Jarvis 16.2.31 - FreakTab

For Exodus Genesis etc you need to search.

DO NOT ask about these on the kodi forum.

You might be able to install Libreelec Amlogic - LibreELEC Forum
 

Looney14

Active Member
Hi what is Libreelec ?

Thanks I'll try install that older version of KODI as i only have android 4.2.2 box and 4.4.2 box

and will search about the video add ons....
 

bubblegum57

Well-known Member
Libreelec is a Linux version of Kodi. But is purely for kodi.

Don't worry, you don't need to know linux.

You can install to & run from micrsd card or usb.

Once installed, you won't see any difference between Libreelec & kodi
 

Looney14

Active Member
ok - im not very tech savy to honest

will stick to kodi
i just wasnt sure if it still worked on older android boxes (4.2.2. and 4.4.2)

that was my main worry- but hopefully it does.....
 

bubblegum57

Well-known Member

Looney14

Active Member
oh - if exodus or another similar video add on doesnt work then there's no point in me trying to bother installing kodi to be honest..........

i basically want kodi for the video add on...
 

bubblegum57

Well-known Member
you do understand that kodi is not meant for illegal sources?
 

Elephant Man

Active Member
Looney14 I will say no, those old boxes cannot play h 265 hevc codec, but first try installing SPMC and see how that works with them.
 
D

Deleted member 765458

Guest
Hi all

I have 2 Android boxes from circa 2015-16.

One is a MX box - with android version 4.2.2.
Second is a K5 box - with android version 4.4.2

Both were bought off ebay - pre installed with stuff and worked fine. but as i've been away from UK they've not really been "maintained" as such and i need some help!

MOBDRO works on both still - so that was a pleasant surprise.

Kodi is the other thing I would like on them - used to use something called exodus BUT that does not work anymore now.

are the versions of my android box able to handle/install kodi? 4.2.2 and 4.4.2
KODI is now on v18 i think.

any advice is appreciated please :)

You need to forget kodi link scrapping addons and go Android based link scrapping apps

21 Best Free Movie Apps To Stream & Download ( February 2019)

Respect copyright owners
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom