Cambridge Audio Melomania Touch

harshone

Standard Member
Just to an observation - the charging issue reported by some, could well be down to a manufacturing issue, present in a batch of Touch's, that CA aren't aware of. That being the case, as with any other issue experienced, it's imperative that affected users contact CA and report it. That gives them the best chance of fixing the issue and of us getting the product we thing we're getting.

Paul

I left feedback complaining about connection issue, which one of their techs responded to by linking me to their FAQ. I replied to it by mentioning the charging issue. I will just email their support too to ensure they see it.
 

selfishclouds

Standard Member
Got my replacement pair this morning (support had already started sending before I’d sent these back, props to them for that) and.... FAITH RESTORED. The charging issue with the case doesn’t seem to affect all units.

The new pair are infinitely more reliable in this regard and because it was the only unreliability I found on the last pair, my only deal breaker was fixed! If you’re also experiencing the charging problem, do tell them and get an exchange. I can’t guarantee that the next pair you get will be fine, but mine were!
 

harshone

Standard Member
Got my replacement pair this morning (support had already started sending before I’d sent these back, props to them for that) and.... FAITH RESTORED. The charging issue with the case doesn’t seem to affect all units.

The new pair are infinitely more reliable in this regard and because it was the only unreliability I found on the last pair, my only deal breaker was fixed! If you’re also experiencing the charging problem, do tell them and get an exchange. I can’t guarantee that the next pair you get will be fine, but mine were!

So you don't have to jiggle around the earbud anymore to get it to charge? I like being able to just drop earbud into place without any haggling.

It might be a quality assurance issue. I guess I might have to go through that replacement process. See if you get that issue over the next day or so before I do it.

Do you use large eartips too? How about the silicone wing? I removed the wing from mine
 

harshone

Standard Member
Also, cambridge audio responded to my complaint about charging issue. They said they are aware of it. The tech also said they are going to have a firmware update soon to help with battery management & connection. Well that's good news.

I don't know what they plan on doing if case is faulty, but I guess they might have to issue a replacement for cases.
 

selfishclouds

Standard Member
So you don't have to jiggle around the earbud anymore to get it to charge? I like being able to just drop earbud into place without any haggling.

It might be a quality assurance issue. I guess I might have to go through that replacement process. See if you get that issue over the next day or so before I do it.

Do you use large eartips too? How about the silicone wing? I removed the wing from mine
Been messing about with them since this morning and it’s a completely different experience. Instead of 9 times out of 10 failing to charge, both earbuds just drop into place and start charging 8 times out of 10, and pressing lightly always gets them charging now, compared to it rarely doing anything with the last pair.

This was the experience (the fixe with the default wings & tips and continues with the largest wings & tips. It’s completely resolved the problem I had, and the magnetic pull of the left (which was the one I had an issue with before) feels a bit stronger, with a consistent snap in across both buds now.

Will let you know if anything changes, but this pair seems to be completely fixed regarding the charging issue.

The only minor annoyances (both pairs) are not deal breakers but:

  • The case lid seems to slide from left to right in a way which I find mildly annoying. This doesn’t mean that the case lid is flimsy, just that they allowed some breathing room (about 4 thin stickers’ thickness) between the raised inner part of the main case and the outer part of the lid. I don’t consider this a big problem and I can understand why that gap would be there, but due to the plastic, the feeling of it sliding left and right is made more noticeable. Again, me being picky and I “fix” this by removing the tolerance by placing paper sticker strips on the side of the inner raised bit.
  • The slight hiss. This is fine for me though as I often forget it’s there.
  • Using these for work calls (I use an external mic although these have an ok mic) can get uncomfortable because they do press against my ears on the edges slightly, so facial expressions like smiling can be less comfortable. Instead, I let these come out over the bottom edge of my ear somewhat, and the sound is pretty much the same, they just stick out a bit more and are more comfortable.

These things are still completely insignificant compared to the charging problemI was having, so I’m glad that’s resolved.
 

selfishclouds

Standard Member
Also, cambridge audio responded to my complaint about charging issue. They said they are aware of it. The tech also said they are going to have a firmware update soon to help with battery management & connection. Well that's good news.

I don't know what they plan on doing if case is faulty, but I guess they might have to issue a replacement for cases.
In my mind the potential issue with charging is likely to stem from any of the following:

- There are small clips I noticed today under the rubber wings, holding the housing of the buds together. If one of these isn’t clipped down properly it will raise the rubber band in that place and might not fit correctly. Unlikely to have been the issue at least with mine bc IIRC the clips are along the top housing so shouldn’t obstruct the case fit at the bottom.

- The size of the recesses were wonky. Doubt this is it either because other tolerances for the case feel exactly the same.

- The wings were wonky. Doubt this too.

- Dodgy pins/electronics were likely the problem in my case (excuse the pun), as a slight wiggle to try and get it charging just made the led flicker and still not charge most of the time.

Could be none of those things of course, I just hope they’ve worked it out. For anyone reading this, my exchanged pair didn’t have the charging issue (as of yet) so there is hope ;)
 

RAINS

Active Member
In my mind the potential issue with charging is likely to stem from any of the following:

- There are small clips I noticed today under the rubber wings, holding the housing of the buds together. If one of these isn’t clipped down properly it will raise the rubber band in that place and might not fit correctly. Unlikely to have been the issue at least with mine bc IIRC the clips are along the top housing so shouldn’t obstruct the case fit at the bottom.

- The size of the recesses were wonky. Doubt this is it either because other tolerances for the case feel exactly the same.

- The wings were wonky. Doubt this too.

- Dodgy pins/electronics were likely the problem in my case (excuse the pun), as a slight wiggle to try and get it charging just made the led flicker and still not charge most of the time.

Could be none of those things of course, I just hope they’ve worked it out. For anyone reading this, my exchanged pair didn’t have the charging issue (as of yet) so there is hope ;)
I note there is now a specific bud and wing fit video online. If you don't get the correct left or right wing on the left or right earbud and it doesn't fit the small lip on each correctly then the fit in the case is around 1mm off the pins therefore not always connected and not charging....an increase in pin height or magnet strength may have been the solution.
 

selfishclouds

Standard Member
I note there is now a specific bud and wing fit video online. If you don't get the correct left or right wing on the left or right earbud and it doesn't fit the small lip on each correctly then the fit in the case is around 1mm off the pins therefore not always connected and not charging....an increase in pin height or magnet strength may have been the solution.
That’s all well and good but it absolutely wasn’t the issue with my pair as that was something I’d checked, and made sure I didn’t change the wings and tips from the default while I was trying to get working, and it doesn’t sound like the issue we’ve seen crop up for others over the last week either (exactly the same symptoms as mine).
 

bradski2620

Novice Member
What is your experience with the call quality with these earbuds? Do you hear white noise from them left bud? I have two pairs and both times people say I sound muffled and hard to hear. Very disappointed. I love the sound and the fit but, the call quality and white noise on both pairs I have make these not usable to a degree.
 

selfishclouds

Standard Member
What is your experience with the call quality with these earbuds? Do you hear white noise from them left bud? I have two pairs and both times people say I sound muffled and hard to hear. Very disappointed. I love the sound and the fit but, the call quality and white noise on both pairs I have make these not usable to a degree.
I hear a slight hiss just generally from both, nothing major in a particular bud though. I don’t have enough experience with the mic to comment on that I’m afraid.
 

harshone

Standard Member
In my mind the potential issue with charging is likely to stem from any of the following:

- There are small clips I noticed today under the rubber wings, holding the housing of the buds together. If one of these isn’t clipped down properly it will raise the rubber band in that place and might not fit correctly. Unlikely to have been the issue at least with mine bc IIRC the clips are along the top housing so shouldn’t obstruct the case fit at the bottom.

- The size of the recesses were wonky. Doubt this is it either because other tolerances for the case feel exactly the same.

- The wings were wonky. Doubt this too.

- Dodgy pins/electronics were likely the problem in my case (excuse the pun), as a slight wiggle to try and get it charging just made the led flicker and still not charge most of the time.

Could be none of those things of course, I just hope they’ve worked it out. For anyone reading this, my exchanged pair didn’t have the charging issue (as of yet) so there is hope ;)

Concerning the first possibility, I don't use the wings (I found the wings uncomfortable since very first use). It still happened even without the wings so I don't think it's the wings.

I don't know about the other possibilities, might be one of those reasons.
 

charliecpr

Standard Member
Hey, I have been following this thread and posted a comment a couple days ago. I decided to bite the bullet and get them. Been very good for me so far.
No charging issues, no connection issues, great sound and fit.
Slight very minimal hiss but barely noticeable.
Not sure on mic quality but I test transparency mode and I believe that uses the mic so if you want to hear your mic quality it might be useful to try it. I have seen reviews that said mic quality was perfectly adequate and had no issues.
 

romainhc

Novice Member
Hi, just received my first pair this afternoon. After looking how to pair it with my Pocophone F1 (very easy procedure), I just had to connect to Left earbud and the Right one get connected by himself. Great sound, not neutral but customisable. When you save an EQ, it "resets" the sound and get back to the setting after 1s ... I thought it was a bug when saving, but understood it had to save / reload the settings.

I have connect / disconnect multiple times, by putting in the charging case or just with the phone bluetooth ON / OFF .... and it gets connected every time !!!! The connection with the phone is in Aptx True Wireless Stereo with the Qualcom chip.

Be aware that the "wings" are made for Left or Right only (it's written inside the rubber) ! And it must go inside the ear, not outside. If it doesn't fit exactly to the buds, then it must be in the wrong way. Take time to test all combinations as it drastically change the sound, really.

The sound is great, the latency very minimal (maybe 1 or 2 frames with a video, so very acceptable).
The touch controls are very useful, and I can easily replace the earbuds without messing with controls.
I find the french female voice prompts very sexy .... i like it !

I test the buds with the last album from "The Weeknd", and it sounds really great, so clean bass and detailed synth !

And FYI, I'm writing while watching a video on my Amazon firestick connected to the Melomania Touch with BT. And if I need to go to pee, I just have to touch an earbud and the video pause .... :D

I was very afraid by reading all the first bugs, but sincerely in my case it's a pleasure to use. I hope it will be the same tomorrow morning !
 

Attachments

  • Screenshot_2021-01-13-21-38-38-148_com.android.settings.jpg
    Screenshot_2021-01-13-21-38-38-148_com.android.settings.jpg
    62.5 KB · Views: 38
Last edited:

bradski2620

Novice Member
Wondering if you are able to select HD audio within your Bluetooth settings? I am really struggling with trying to figure out why people say I sound muffled when they hear me on these buds? Never had this issue with my samsung galaxy buds plus.
Screenshot_20210113-205219.jpg
 

harshone

Standard Member
I have connect / disconnect multiple times, by putting in the charging case or just with the phone bluetooth ON / OFF .... and it gets connected every time !!!! The connection with the phone is in Aptx True Wireless Stereo with the Qualcom chip.

What's that? I have Google Pixel 3 but not sure what Aptx true wireless stereo mode is. Is that the same as regular aptx?

What phone do you use?

Edit: Google search shows Google hasn't integrated Aptx true wireless stereo mode in their Pixels even though the Qualcomm 845 chips support it unfortunately 😞
 
Last edited:

romainhc

Novice Member
What's that? I have Google Pixel 3 but not sure what Aptx true wireless stereo mode is. Is that the same as regular aptx?

What phone do you use?

Edit: Google search shows Google hasn't integrated Aptx true wireless stereo mode in their Pixels even though the Qualcomm 845 chips support it unfortunately 😞

I think the TWS from Qualcom enhance a little bit the signal (audio, consumption and connection), but it is still Aptx.

This morning, no connection problem at all ! Only some wind in micophones with the "transparence" mode.
 

Grieve14

Standard Member
I have been watching this thread closely with an interest in buying the Melomania Touch. Initially it seems people were having issues with these left, right and centre. Now its starting to look a bit more positive.

These appear to be everything I would want from a wireless earbud in terms of features, cost and sound, but I'm still 50/50. The addition of wireless charging would have probably been a deal breaker for me though.

Interested to see how the Galaxy Buds Pro, that are being announced today, stack up. They will obviously be more expensive, but they will have ANC, wireless charging and if they follow suit of previous models then NO connectivity issues.

Would love to see a comparison of these 2 but I'm too impatient to wait for that to be on youtube or somewhere!
 
Hi All,

I just received the Melomania Touch yesterday. I initially bought the Melomania 1 on sale around Christmas after eyeing them for a year or so. The fit wasn't great for me, but I was extremely impressed with the sound. When I discovered there was a new, more ergonomic model on the way I returned the 1's.

I found this forum when looking for reviews of the Melomania Touch, in anticipation of my pair arriving. So I just registered to share my own experience so far.

I connected from a Samsung A71 phone. Initial connection took a while, maybe 4 or 5 tries following the reset instruction in between. I expected this after reading the previous posts.

I immediately updated from firmware 11.2 to 11.8.

The fit is very good for me, using the largest option for both earbuds and fins. The seal is very good as well. I'm planning on using them on my bicycle as well and will update about wind noise later. (edit: They do still let some wind noise through, but for me it's bearable)

I had a stable connection for the first couple of hours of use, listening almost continuously while working from home. I placed the buds back in the case a couple of times and they reconnected without issue. Sometimes I had to manipulate them a bit before they showed the red charging light. I have the impression that using the biggest fins makes it somewhat more difficult to get the buds in perfect charging position.

Sound quality is superb, I listened to some 90's hiphop, Bach Cantates, Mac Miller and the playlist 'Songs to test headphones with' on Spotify. Everything sounded very nice. Very detailed and clear listening experience. The different EQ profiles are useful and respond well when changing them.

Call quality was poor according to 1 colleague. From my end it sounded good.

I had to reset the pair in the evening as they suddenly wouldn't connect to my phone anymore. No problems connecting to my phone since, been using them today as well.

More annoyingly, connecting to my LG smart TV in the bedroom simply did not work. I could pair with the TV, but immediately disconnected automatically every time. They also did not seem to work together at all. The TV connected L or R individually and then immediately disconnected. I never got the impression that the TV was aware this was a pair of devices that were supposed to work together. I retried 10 times or so, resetting in between, before giving up.

Conclusion: Very happy with the fit and sound. I'm mostly planning on using the buds with my phone, so for the moment the TV connection issue is not really a dealbreaker for me. But from a general consumer standpoint it's totally unacceptable. I'm curious if these connection issues will be be able to get fixed with software updates.
 
Last edited:

JayCee

Distinguished Member
Does your TV work with any other Bluetooth headphones?
Certain models of LG TV's from a few years ago only work with LG branded Bluetooth headphones.
 

harshone

Standard Member
Hi All,

I just received the Melomania Touch yesterday. I initially bought the Melomania 1 on sale around Christmas after eyeing them for a year or so. The fit wasn't great for me, but I was extremely impressed with the sound. When I discovered there was a new, more ergonomic model on the way I returned the 1's.

I found this forum when looking for reviews of the Melomania Touch, in anticipation of my pair arrving. So I just registered to share my own experience so far.

I connected from a Samsung A71 phone. Initial connection took a while, maybe 4 or 5 tries following the reset instruction in between. I excpected this after reading all the previous posts.

I immediately updated from firmware 11.2 to 11.8 after opening the box.

The fit is very good for me, using the largest option for both earbuds and fins. The seal is very good as well. I'm planning on using them on my bicycle as well and will update about wind noise later.

I had a stable connection for the first couple of hours of use, listening almost continuously while working from home. I placed the buds back in the case a couple of times and they reconnected without issue. Sometimes I had to manipulate them a bit before they showed the red charging light. I have the impression that using the biggest fins makes it somewhat more difficult to get the buds in perfect charging position.

Sound quality is superb, I listened to some 90's hiphop, Bach Cantates, Mac Miller and the playlist 'Songs to test headphones with' on Spotify. Everything sounded very nice. The different EQ profiles are useful and respond well when changing them.

Call quality was poor according to 1 colleague. From my end it sounded good.

I had to reset the pair in the evening as they suddenly wouldn't connect to my phone anymore. No problems connecting to my phone since, been using them today as well.

More annoyingly, connecting to my LG smart TV in the bedroom simply did not work. I could pair with the TV, but automatically disconnected immediately every time. They also did not seem to work together at all. The TV connected L or R indivudually and then immediately disconnected. I never got the impression that the TV was aware this was a pair of devices that were supposed to work together. I retried 10 times or so, resetting in between, before giving up.

Conclusion: Very happy with the fit and sound. I'm mostly planning on using the buds with my phone, so for the moment the TV connection issue is not really a dealbreaker for me. But from a general consumer standpoint it's totally unacceptable. I'm curious if these connection issues will be be able to get fixed with software updates.

I don't know about you, but I am giving them 3 more weeks (for a total of 1 month) to get some firmware improvements or else I'm jumping ship.

Occasionally they randomly disconnect but been stable. I still have to jiggle them a bit to get red charging light on, but it is not too bad.
 
Last edited:
My wife's JBL heaphones work perfectly with the LG TV, it's the LG 32LK6200. We bought it in July 2020.

As for possibly returning them, I'm actually not sure yet. I'll see how I feel in a couple of days / weeks. I like them a lot mostly and just hope there will be improvements soon. I would hate to have to return them because the sound and fit are so good.
 
Last edited:

jijiko1

Novice Member
Hi all,
i already have Melomania 1, but the call quality is not good. I listen music a lot and when i say a lot i mean it. I come from open sound AKG K701,vinyl records ,amp and dac so i love music.
And CA sounds almost excellent.

I want Melomania touch but i see from your reviews that the pairing issues still exist.
The most important factor as i said before is the call quality, because i think is very very important.

Can you tell me please or is there any call quality test to tell me if mostly in noisy environment and with one earbud connected the how is call quality?
 

charliecpr

Standard Member
Wondering if you are able to select HD audio within your Bluetooth settings? I am really struggling with trying to figure out why people say I sound muffled when they hear me on these buds? Never had this issue with my samsung galaxy buds plus.View attachment 1440914
I suggest getting a voice recording app and testing the voice quality yourself. It might be a fault on your earbuds meaning you need a replacement or it might be something else.
 

TheWarmInRain

Novice Member
What's that? I have Google Pixel 3 but not sure what Aptx true wireless stereo mode is. Is that the same as regular aptx?

What phone do you use?

Edit: Google search shows Google hasn't integrated Aptx true wireless stereo mode in their Pixels even though the Qualcomm 845 chips support it unfortunately 😞

I saw on google website that my Pixel 4A supports this: AptX and AptX HD, and Pixel 3 the same, but I don't know difference between aptx true wireless and the rest ones.
 

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...

Latest News

What's new on Disney+ UK for February 2021
  • By Andy Bassett
  • Published
Focal releases 1000 Series integrated speakers
  • By Andy Bassett
  • Published
Klipsch announces ProMedia 2.1 BT speaker set
  • By Andy Bassett
  • Published
No Time to Die gets pushed to 8th Oct 2021
  • By Andy Bassett
  • Published
KEF announces KC62 subwoofer with new Uni-Core technology
  • By Andy Bassett
  • Published
Top Bottom