Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

Cable Extension Required for KENWOOD A-58 Amp

Discussion in 'Hi-Fi Stereo Systems & Separates' started by Moncs, Jun 21, 2003.

  1. Moncs

    Moncs
    Standard Member

    Joined:
    Jan 14, 2002
    Messages:
    467
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Edinburgh, Scotland
    Ratings:
    +1
    Hi Everyone,

    Im hoping someone can point me in the right direction.

    I have a Kenwood seperates system A-58 amp, I recently bought a Alphason glass unit to sit it on, now however the parallel cable from the radio to the amp does not reach.

    I need an extention rather than a new cord as one end is hard wired into the radio . Can anyone help or point me in the direction of a good website as I have tried all the local shops up here in Edinburgh with no luck
     
  2. Moncs

    Moncs
    Standard Member

    Joined:
    Jan 14, 2002
    Messages:
    467
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Edinburgh, Scotland
    Ratings:
    +1
    I take it thats a no then.... :confused:
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice