CA 640H problem

treblecel

Active Member
My 640H is fantastic...when its working :rolleyes:

It wont switch on, gets stuck in standby for anything up to 3 hours!
Sometimes I can see three black bars in the screen display (although it doesnt light up).
Then after many attempts it will simply come on like nothing was wrong.
This is the third time in as many days and it is very frustrating.

Ive tried to register with the customer service centre on the CA website, but nothing happens when i hit the submit button (yes i have filled in all fields and i am allowing popups).

Anyone have a contact number or email for cambridge audio?
 

enmac1

Standard Member
This happened to my first two CA640H. I sent them back. The third has been fine and I'm glad I persevered with it as it is a fantastic bit of kit. Richer Sounds replaced the faulty ones with no bother at all.
 

treblecel

Active Member
This happened to my first two CA640H. I sent them back. The third has been fine and I'm glad I persevered with it as it is a fantastic bit of kit. Richer Sounds replaced the faulty ones with no bother at all.

So its best to get in touch with Richer Sounds then?
 

Ed Selley

AVF Reviewer
We have got the support system back up and running (typical website thing- change one option, lose 373 other ones) so give us a run down of what you've been up to and we'll see if we can help out.
Ed
 

treblecel

Active Member
Ok thanks, i've submitted a query on the customer care part of CA website now.
 

treblecel

Active Member
So here we are, one month on and I still dont have a working 640H:rolleyes:

To cut a long story short it was picked up by cambridge audio for repair.
One week later I get it back and it has exactly the same problem.
I took it out of the box and it took FIVE hours before I could get it out of standby.
Ok, so its cold and maybe needs time to reach room temperature, I thought.
Then this morning it worked fine, and again at lunchtime its fine.
Now this evening its stuck again:thumbsdow

I'm extremely disappointed and frustrated by this. I have been very patient until now but enough is enough.

It looks like its back to Richersounds at the weekend for a replacement or a refund.
 

treblecel

Active Member
This happened to my first two CA640H. I sent them back. The third has been fine and I'm glad I persevered with it as it is a fantastic bit of kit. Richer Sounds replaced the faulty ones with no bother at all.

Apparently CA can find nothing wrong with it, but obviously there is something amiss.
If it happened to yours as well then that only confirms it for me.

Hopefully the next one will be ok:smashin:
 

enmac1

Standard Member
I bought mine through their internet service (I live over 100 miles from their nearest shop). The first two never worked properly, they came on and hung, just like your computer when it crashes. When I rang their sales support people they sent a new one and picked up the faulty one at the same time, there was never any question of trying to repair it as it was clearly faulty when it arrived. The third one has been fine.
 

treblecel

Active Member
Well the message I'm getting from CA customer service is that they powered it up from standby 10 times, and can find no fault.
On a good day i could probably get it to power up 10 times in a row also.
Its actually on as I type this, and working wonderfully well.
Its the times that it wont come on that bother me:rolleyes:

Sometimes the wee screen just shows two rows of black squares when switched on then nothing.
Other times it just wont respond from standby.
I think CA are under the impression that I'm making this up just to annoy them.

Arghhhhhhhhhhhhhhhhhhhhhhhh!!!
 

russraff

Well-known Member
If it were me, I would be tempted to make the trip to a RS shop and demonstrate the issue, after agreeing with the manager that this is okay. I would get them (it is all the same company after all) to agree that there is an issue and send it to CA from there. If you don't you will be stuck with a bit of kit that you will never be happy with (it should switch on instantly with no issues - AT ALL). What's worth thinking about is that when they work the CA640H seem to be superb units, so it's perhaps worth the stretch, IMO.

Russell
 

treblecel

Active Member
Just thought I'd post an update on this.
I persevered with the machine, and through time its started working.
Nowadays if it doesnt power up from standby at first attempt, it does it on the second attempt (so I can live with that).

Ive now copied loads of music across wirelessly from my laptop, and I'm currently in the process of storing cd's on it in uncompressed format.

The sound is awesome :clap:
 

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...
Top Bottom