• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Buzzing sound and No satellite signal on Sky digibox

Steven Y2T

Standard Member
Last year I upgraded to Sky+, but kept the original sky digital box and used it in a bedroom for multi-room. 2 days ago the Sky digital box started to make a buzzing sound when I switched it on and I got a "No satellite signal is being received" message. I did all of the tests, which it suggested on the Sky website, but none of them worked.

The Sky+ box is working fine.

I don't know if it's worth getting someone out to fix it as the box is 9 years old now or whether to upgrade the digital box for a sky+ box if that is possible to have Sky+ as the multi-room box as well.

Anyone else had a similar problem with their digital box?
 

kenedin

Prominent Member
That buzzing sound is probably the PSU on the way out. Also, you've got 'No Satellite Signals'. Classic symptoms. Time for a replacement.
 

Stevenage Neil

Distinguished Member
You can pick up a Sky+ box off flea bay. All you will need then is an additional cable from the LNB and get Sky to pair your card with the new box.
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom