• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Buzzing issue with subwoofer

Wondering if anyone can help me with this issue I'm having.

I have recently changed my living room round so I moved the subwoofer and now I'm getting this loud buzzing sound from the subwoofer.

I have a Onkyo 3405.

How can I fix this?
 

Chuff

Established Member
Is it plugged into a different mains point?

Could be an earthing issue with that mains point or one of your pieces of av kit.
 
Chuff said:
Is it plugged into a different mains point?

Could be an earthing issue with that mains point or one of your pieces of av kit.

No there is not a mains point from the sub.
 

Chuff

Established Member
Ok back to basics......

So it is a passive powered sub?

Is your av kit plugged into a different mains point now?

Do you have a satelite and/or freeview box plugged in as well? Could be worth unplugging from the mains each piece of equipment one at a time and see if the buzzing stops.
 
Chuff said:
Ok back to basics......

So it is a passive powered sub?

Is your av kit plugged into a different mains point now?

Do you have a satelite and/or freeview box plugged in as well? Could be worth unplugging from the mains each piece of equipment one at a time and see if the buzzing stops.

Yeah it's passive subwoofer,yeah I tried a different mains socket still buzzing.

I have virgin media plugged into my av receiver and to the mains. I will try to unplug them and see if it stops.i can tell you it's worse when the ps3 is on.
 

The latest video from AVForums

Spielberg, Shyamalan, Aronofsky, Chazelle, Eddie Murphy and Mel Gibson - all the latest movies
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom