Buzzing from FS2 Subwoofer

Discussion in 'Subwoofers' started by gedclink, Apr 22, 2002.

  1. gedclink

    gedclink
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi folks...

    Got the mission FS2 set over a year ago..It came with the enclosed subwoofer...

    Only recently I've noticed that the Sub appears to be making a weird noise - almost equivalent to a low level " buzz "..

    This is most noticeable when the amp is turned down low / muted or indeed when I switch off the television set / cable box.

    The sub is connected to a Toshiba amp via the supplied umbilical leads. The sub has it's own power switch on the front of it.

    It will eventually stop buzzing about 10 minutes when the following occurs

    1) The amplifier has been off for about 10 minutes.
    2) The power switch on the front of the sub is switched off then on.

    What is happening...Any clues or more info needed

    Thanks in anticipation
     
  2. MartinN

    MartinN
    Active Member

    Joined:
    Mar 23, 2001
    Messages:
    58
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +11
    I've got the same problem, don't get your hopes up! Although in my case the hiss never goes away - until the sub goes into standby mode, or is turned off.

    I was told by the shop that all sub woofers suffer from some sort of hiss (speaker & built in amp being too close to each other).

    I've tried a few things, making sure the amp is earthed ok, but I get the hiss even if the sub isn't connected to the the amp.

    I hope you find an answer!

    Martin
     
  3. gedclink

    gedclink
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Mmmh..
    Thanks Martin...Need to try and sit further away from it.

    I hadn't really noticed it until recently when I was farting about with settings so I'll need to revisit them..

    When the Sub goes into standby it disappears but switching the sub on and off also cures it until it receives a signal from the amp...

    Is switching it on & off putting it into standby until the amp input kicks in?
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice