Business Laptop Dual

johnhol

Novice Member
I see hundreeds of threads asking which laptop should i buy but i'm adding another as none cover my needs.

I currently have a Compaq A900 Dual Core 17inch

I use my laptop nearl all day everyday and after a year it's just too slow. It gets too hot and the fan stays on most the time due to multiple apps running.

Laptop is clean and has win7 installed fresh, fans and vents cleared - i just think it can't handle the workload i need.

Don't want to spend more than £450.....any ideas on would be a good option?

Was looking at the X5DIN though everywhere's sold out. Heard ASUS are the most reliable in the US and the prices seem reasonable.

Any advice would be gratefully received. :smashin:
 
Last edited:

brookheather

Distinguished Member
Does task manager show 100% cpu? Your dual core cpu should run Win 7 fine so it is a little bit odd - I assume you have 2GB of ram fitted? Have you installed speedfan to see what temperature the cpu is running at? One thing you could try is to remove the heatsink from the cpu and clean off the old thermal paste and apply some fresh paste. Have you checked that the fan is actually running - they can fail and that will mean the cpu heats up and throttles down as it can't get cool.

- Simon.
 

johnhol

Novice Member
No CPU rarely touches 100% and the temp goes up to 80 degrees when just running chrome...

Even the touchpad gets hot.....tech guys said it wasn't a hardware fault so any repairs wouldn't be covered by the warranty....though it;s always been a warm lappy.

And yes it has 2gb.....can't expand which is another reason i'm thinking of upgrading
 

brookheather

Distinguished Member
Sounds like the cooling fan isn't working - double check that it is spinning and you can feel hot air being blown out of the laptop...
 

johnhol

Novice Member
Spinning and blowing hot air out......it's all working.

Fan has been on non stop for the last 3 hours......and i've only been running outlook and chrome
 

brookheather

Distinguished Member

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month
Top Bottom