• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Buffalo Linkstation Live NAS 1TB - problem and solution

Tobers

Well-known Member
Howdy all. Hopefully this might help people who have the same issue.

I bought a 1TB Buffalo Linkstation Live NAS box to backup all my photos and general "stuff".

Out of the box it is really quite a capable bit of kit with very workable web access, bittorrent client, FTP capability as well as the usual backup capability. So under the stairs it went with the wireless router, and I configured all PCs in the house to start backing up to it with the rather excellent and unobtrusive Memeo backup utility that came with the unit.

All went swimmingly for several months, with the unit on permamently (so I could access it when away from home via the web, which saved my bacon with a couple of photography clients).

Then a couple of days ago my PC wouldn't connect to it.

So started a painful process to get it working again.

Firstly, Buffalo tech support were excellent on the phone - very responsive and knew what they were talking about. However their written emailed instructions were a bit vague and missing things that someone who wasn't very technical would really struggle with.

The LSNavigator software could still find the NAS, and it was still attached to the network & running, but the LSNavigator showed the NAS to be in "EM mode" or Emergency Mode i.e. it'd died.

The solution given initially was to reinstall the firmware. This involved using their firmware updater downloaded from the Buffalo site, but frigging the .ini file of the updater to ignore the version number (v1.07) on the NAS and force the update (otherwise it stops you doing the update as the firmware versions are the same) and allow debug mode. Also, the process involves you connecting the NAS to your PC with a LAN cable, and frigging the IP settings on your PC to match those on the NAS. What a pain!!

That was done after about 10 tries and much swearing. Make sure that you reset the admin password on the NAS to "password" otherwise it wont work. Doh!!

The problem still recurred any time an app tried to write to the NAS. The NAS would just hit EM mode again. Reading from it was working fine.

Next solution offered by Buffalo was to reformat and repartition the NAS. Woohoo - that would delete all the data on it. Great!

So I bought a 500GB USB drive and backed the unique data on NAS up to it. I had my iTunes library on the NAS but not on my PC, otherwise everything else was duplicated, so I just copied over the iTunes stuff to the USB drive.

Then, a further battle ensued to further frig the LSUpdater app to reformat and rebuild the partition. This involves clicking on the title bar of the firmware updater window, selecting debug mode, and then ticking the relevant reformat & repartition options. Usual IP address nightmare as the NAS gave itself a new IP address each time it turned on, which I then had to match on my PC. Also, firewall and wireless turned off on the PC during this process. Gaaggghhh!!!

Eventually, the NAS rebuilt itself and is now back under the stairs working properly. But what a hassle! Buffalo really need to get their diagnosis & repair process streamlined as it took several hours on the phone and many hours of trying to get it to work. Anyone not knowledgable about IP addresses etc would never manage to repair it.

I've now updated my backup setup, with a dual backup process. The 500GB USB drive directly connected to my PC and the NAS box under the stairs, both backing up the same files. I'm much more comfortable now!

As to the original cause of the problem - no idea. Could have been a power cut, or just a disk glitch.

Tobers
 

conan

Active Member
Nice post, I'm interested as I am planing to buy one of the 2TB versions of these in the next couple of weeks. I currently have a Mactor shared storage but its getting full and is 4 years old now.

Seems like you find the unit pretty good overall?

My main concern is backing up the data. I don't want to raid the unit as I would then need two of them to achieve 2TB of storage. So I'm thinking of fitting a couple of big HDD's into my main rig for backup.
 

Tobers

Well-known Member
Yep - overall it's a pretty good bit of kit (if you forgive the fact it went doo-lally). The people who designed the user interface and manual need some training from Apple or Google to make it all clearer and simpler, but aside from that and the problem resurrecting it, it's cool.

FWIW I did buy a MyBook World Edition initially which promised built-in web access, but when I installed it the web access turned out to be a pay-for service which I was really hacked off about. The Buffalo approach is much better.
 

caz100uk

Standard Member
Thanks so much for this - I didn't realise you had to connect the LAN cable locally, as soon as I did that and manually set the IP address on my PC, the firmware update worked fine. I've done a bit of reading on this subject, and nowhere else did I see that you had to locally connect! Anyway, my Buffalo is up and working again, thanks so much.:clap:
 

IanW1977

Well-known Member
Just had to do this too - Will see if it works.

Think I will send it back anyway as it's a month old so will see what they say tomorrow
 

IanW1977

Well-known Member
Still broke - Won't come out of EM mode even after re-flashing the firmware.
Tried the firmware again and get a TCP error.
 

silvercue

Distinguished Member
Hi all.

Very interesting post. I had the same problem a few weeks ago - EM Mode. But could not solve, though I did retreive data (see below).

First thing is that I could not connect to the LS. No data could be read. Always showed as EM mode. I used the forums and tried everything. Occassionally I got the IP address changed then I had the password problems etc. Updating firmware always failed right at the end. Tech support I thought were not actually very able to help. The forum users equally unable to assist.....and the forum is very dead too.

So I found a seperate solution myself but only to accessing the data.

I took the drive out of the NAS unit and put it into my PC. I needed to copy to a new NAS (Ready Nas Ultra 2). However, Windows cannot read or even recognise the disk as it is XFS format. I got a program that allowed me to see whether there are files there and confimr they are ok, but you can't copy or move from that program.

So I got a Ubuntu Live disk, installed Ubuntu, connected new NAS and copied all the 1TB of data accoss the LAN to the new NAS. Ubuntu can read that file system as well as Windows ones.

I kept the old drive in the PC for a dual boot Windows/Ubuntu PC with a 1TB drive for back ups.

However, I would not recomend Buffalo LSs. They are slow to copy, hideously slow to delete, especially multiple small files, they go into EM mode as described above. Also the BT client seems to not work with many trackers now.

Overall, you get what you pay for, they are cheap and a good "entry level" NAS, but do some good back ups of your data!!
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom