Both my memory sticks broke when plugged into my laptop

I have two memory sticks, one 16gb Integral which I have been using with no problems for the last 18 months and one MicroSD reader with an 8gb card in it, they both broke after plugging them into my Macbook Pro.

The 16gb Integral has been working fine for the last 18 months, until I put it into my Macbook Pro a few days ago and nothing, not even found in Disk Utility, tried starting it up in windows. Nothing in Disk Management no drive in explorer. So I put it in my PS3, nothing, I put it into another windows computer Explorer finds a removable disk drive and assigns it as E:, but try to open it and it says there is nothing there, go into Disk Management it can see there is something there it says Removable (E:) No Media. It was working perfectly in the last computer it was in around 8 hours before.

The MicroSD reader is not reconised at all on anything, I have tried two MicroSD cards in it.
 

DVD-Man

Distinguished Member
Probably disconnected whilst writing to them, try a format in a PC.

Liam
 
Both were ejected before removing, the MicroSD card works fine in my phone just not the card reader. Is there any way I can format the Integral stick even though the computer doesn't know what it is?
 
A Ubuntu Live Disk can't find it, and the HP USB tool finds it as USB DISK 2.0 PMP (0 MB) and when I try to format it, it says "There is no media in the specified device"
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom