1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Boo Hoo My plasma is dead

Discussion in 'Plasma TVs' started by miniman, Mar 13, 2005.

  1. miniman

    miniman
    Active Member

    Joined:
    Apr 14, 2003
    Messages:
    567
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Birmingham
    Ratings:
    +7
    I can't believe it, there i was watching the footie and my plasma (pioneer 503mxe) turns into a acid nightmare, all funny colours (not funny from where i was sitting :eek: ) with a black horizontal line in the middle. I have done the usual switching off the power, checked the iscan but no good. The mad thing is when i switch it back on i still have an image on top that was on the tv when it went off. I have called john lewis and am waiting for a return call (tuesday i suppose). Does anyone have any ideas ? Can you do a system reset or should i just wait? Thanks Mark
     
  2. Blu Ray

    Blu Ray
    Active Member

    Joined:
    Jun 14, 2004
    Messages:
    495
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Chorley, Lancs
    Ratings:
    +12
    IMO I'd wait, they might get a bit funny if they know you've been fidling with the settings too much. It does sound knackered though thank god for the JL 5 year warranty eh?
     
  3. miniman

    miniman
    Active Member

    Joined:
    Apr 14, 2003
    Messages:
    567
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Birmingham
    Ratings:
    +7
    Too right. I'm really glad i went to john lewis. Oh well heres hoping for a new replacement
     

Share This Page

Loading...