Bluray copies appearing as SD on TV from HTPC

madman236

Active Member
Hi all,

Looking for some advice please on my HTPC.

In short I’ve connected my HTPC to TV via HDMI (long 10m cable from graphics card output to Samsung TV directly) for video and optical for audio directly into my receiver. I download bluray movies, however when I’m viewing movies, the video quality looks distinctly standard definition rather than 1080p. I can confirm the source files are bluray quality (50gb, high bitrate)

Is there a specific setting I need to apply in either Windows or Kodi to improve the video quality? I’m using Kodi as my interface.

My HTPC build:

Processor (CPU) Intel® Core™i7 Quad Core Processor i7-4770k (3.5GHz) 8MB Cache Motherboard ASUS® MAXIMUS VI HERO: PCI-e 3.0, SATA 3.0, USB3.0 Memory (RAM) 8GB KINGSTON DUAL-DDR3 1600MHz (1 x 8GB) Graphics Card 2GB NVIDIA GEFORCE GTX 770 - 2 DVI, HDMI, DP - 3D Vision Ready Sound Card - ONBOARD 6 CHANNEL (5.1) HIGH DEF AUDIO (AS STANDARD) OS – Win 8.1 64bit

Thanks
 

slave1

Active Member
Have you tried changing the resolution of the PC output in the nVidia settings?
Right click on blank home screen of Windows (works for W10, personally I skipped W8).

PS Just upgrade to W10
 

madman236

Active Member
Have you tried changing the resolution of the PC output in the nVidia settings?
Right click on blank home screen of Windows (works for W10, personally I skipped W8).

PS Just upgrade to W10

Yes thats what I initially amended. I think the problem may be the source file itself, though they are downloads of bluray rips as mentioned above. When I look at Amazon prime content such as the grand tour you can tell the difference between 1080p HD and my source file.

Failing that, it could be my settings within Kodi.

Any suggestions?
 

slave1

Active Member
Mediainfo is a small file that will tell you the resolution of any video file, try downloading it as perhaps it’s a crappy resolution file?
 

next010

Distinguished Member
Things to try
* make sure Nvidia driver is outputting 0-255 full RGB, same goes for TV at other end, (Samsung TV's require a specific PC mode to be activated).

* try using something other than Kodi, like Plex and see if the quality issues still persist.

* the best video renderer for the PC is MadVR but I think a custom Kodi build is required to use it, there are other options like Zoom player which has a basic HTPC mode and that can use it with less hassle. Emby is another Plex like but can use MadVR but I think Emby now requires a sub to view content, not sure must double check.
 

madman236

Active Member
sorry all for the delay in replying, been a bit manic due to Christmas. I think its a combination of the source files and the tv mode setting. When connected to the PC I get 1920x1080p at 60p but when the movie starts it switches to 24p. I assume thats due to Kodi automatically changing to the best frame rate of the movie?
My samsung ue55f8000 doesn't appear to have a dedicated pc mode so i have set the picture to cinema. Am I missing something?
 

next010

Distinguished Member
To activate PC mode on Samsungs you must change the input label on the HDMI port the PC is connected to "PC" from the list. Then the stock display presets will be disabled and replaced by a PC based one.

settings\player\video
In Kodi expert mode, you can disable 24Hz support here or alternatively enable sync playback to display which will smooth playback at 60Hz with no switching at the cost of audio being limited to stereo.

settings\system\display
In Kodi expert mode under display make sure 16-235 is disabled with PC mode active on Samsung it is expecting a 0-255 normal PC signal.
 

duffbeerdrinker

Distinguished Member
I suspect the problem lies with your source file. Downloaded files are often troublesome and even if MediaInfo reports it as 1080p - it may well be an SD source.
 

The latest video from AVForums

Samsung S95B Update, B&W Panorama 3 & Q Acoustics Reviews, HDR PQ EOTF/Gamma Calibration Discussion
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom