1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Blaupunkt Cd/radio For 2002 Corsa

Discussion in 'Portable Disc & Media Players & Recorders' started by darren787, Dec 29, 2004.

  1. darren787

    darren787
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have just bought a Blaupunkt CD/radio which is standard fit in Europe for the Corsa/Meriva.

    The new unit came with the double din basket (exactly same as the one in the car that houses the Philips CA 2004), and the 3 ISO connectors are the same as those for the Philips.

    Unfortunately the Blaupunkt did not come with a wiring diagram or sticker of how the ISO connectors should be wired, but suffice to say that the wiring cannot be the same as it is for the Philips.

    The HU display does not work, and although I have had the Blaupunkt CD/radio working, it definitely isn't right as the steering wheel controls don't work, the HU display does not work, and the unit will not power up without the ignition being on. The only part that works with the ignition off is the flashing security LED.

    I don't think the Blaupunkt requires adaptor leads as it is GM OE in Europe, but I really do believe the order of the wires within the 3 ISOs is different to that here for the Philips unit.

    Has anyone come across this before, or know of how it can be sorted. Teh pins in the back of the unit are not numbered either.

    Any help/advice gratefully received.

    Thanks
     
  2. Crocodile

    Crocodile
    Distinguished Member

    Joined:
    Nov 4, 2002
    Messages:
    15,300
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +4,572
    PM your e-mail address & I'll send you a scan of the label on the Blaupunkt 2003 radio/cassette that came out of the missus' 2001 Corsa. Don't know if it will be of any help but it's a start!
     
  3. lynx

    lynx
    Well-known Member

    Joined:
    Jan 20, 2002
    Messages:
    4,633
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    It always rains.
    Ratings:
    +301
    You need to swap the positions of the switched +ve and the unswitched +ve to resolve the power up issues, from memory it's the Blue and Yellow conductors that require to be swapped.
     

Share This Page

Loading...