• Welcome to AVForums running Xenforo 2.2. The upgrade from 2.1 was successful and finished in just 90 minutes, well before 8am. The most notable changes in 2.2 are listed in this post.

Black Ops III (3) Play and Help Thread.

NewBeetle

Distinguished Member
Now the game's out thought we'd probably need this thread.

Million times better than advanced warfare, it actually feels like COD again.
 

NewBeetle

Distinguished Member
I bought my first *Rare (the one that costs 30 tokens) supply drop from the black market, I got 2 common guns and one rare. Does anyone know how I can view/equip them as I can't find which ones I got now.
 

gunner84

Distinguished Member
I bought my first *Rare (the one that costs 30 tokens) supply drop from the black market, I got 2 common guns and one rare. Does anyone know how I can view/equip them as I can't find which ones I got now.

I thought supply drops were just attachments, cosmetic items and taunts and so on. Didn't think they included weapons.
 

NewBeetle

Distinguished Member
I thought supply drops were just attachments, cosmetic items and taunts and so on. Didn't think they included weapons.

Dunno, pretty sure I got 3 guns, unless it was just the camo's for them. Can't tell as I probably haven't 'unlocked' the guns yet, even if I could remember them.
 

Marv

Member
Anyone else getting "Awaiting Connection 1,2,3,4,5......" then "lost connection from host"

That's all i get trying to play online. Not managed one game yet.
 

NightHawk

Well-known Member
Anyone else getting "Awaiting Connection 1,2,3,4,5......" then "lost connection from host"

That's all i get trying to play online. Not managed one game yet.
Trick is to let the game load and don't press x or anything till you see the number in top right corner change from 30.0.0.0 to something else. Then press x. Gives a chance for the latest software update to load.
 

Henborg

Active Member
Not sure If I am posting this in the right section so apologies if not.

For some reason this time around my Nat type is moderate I have attempted to put my ps4 in dmz by giving it a static IP. No joy.

I had a look at this port forwarding tho it's over my head lol. When I go to the port forwarding web site I cant find my router sky hub.

I watched god knows how many you tube videos on this. Got to the point now where I am about to smash the router lol.

If anyone has any ideas or a dummy's guide that would be most appreciated. I have only got about 4 games. :(
 

Dirtschmooz

Well-known Member
port forwarding just 3075 in my virgin superhub changed me from
moderate to open nat. not sure about sky router
 

prezzy

Well-known Member
Wired or wireless?

Mine was showing moderate earlier and I remembered I had unplugged the ethernet, stuck that back in and back to open.

I have my router and port forwarding all set up fine over wireless it shows as moderate though.
 

Henborg

Active Member
Wired connection. Tho at this stage I take anything lol
 

BluWarfareHD09

Well-known Member
I've got my PS4 port forwarded and I'm still getting a moderate NAT. Doesn't seem to be affecting me, as I've just been able to get top of my team in my first ever match on this. Think it might be my new connection helping, aswell as ping is only 15ms max in that match.

 

Attachments

  • COD Black Ops 3 First MP Match.png
    COD Black Ops 3 First MP Match.png
    2.3 MB · Views: 80

AllThatDaz

Well-known Member
I've got an open NAT and it still searches for games for quite a while. Wired connection and static IP too!
 

NewBeetle

Distinguished Member
Shocking last night, me and a friend, both open NAT status, partied up it simply would not join a single game, searching separately it finds a game in about 2 seconds.


*EDIT: this game is driving me to distraction, My PS4 is connected at a bandwith of 10.5Mbps, black ops 3 with open NAT is now lagging me out and saying connection is 545kbps.
 
Last edited:

NightHawk

Well-known Member
[/URL]

Think that's the page?
Check your IP address on PS4 network settings by viewing connection status. If it matches, your PS4 should be in DMZ with open NAT.

If not put the correct IP address from your PS4 to the router page.

Delete all port forward settings too.
 

Henborg

Active Member
Yeah it matches. Maybe a sky bb thing?

When playing solo no real issues but no fun in that. Seems like I can join party's tho the few games that start I am on two bar connection and everyone is pausing across the screen.

Might be just handier to get a new router this sky hub is at least a few years old
 
Last edited:

NightHawk

Well-known Member
Yeah it matches. Maybe a sky bb thing?

When playing solo no real issues but no fun in that. Seems like I can join party's tho the few games that start I am on two bar connection and everyone is pausing across the screen.

Might be just handier to get a new router this sky hub is at least a few years old
Or ask them to send you a new router as this one is obviously faulty.
 

Henborg

Active Member
Yeah just did that this second told them had power cut and router didn't come back on. If I told them about ports and dmz mode etc am sure they would not be keen to replace it unless I paid for it. Which of course I didn't lol

Cheers nh for getting a look at that for me anyways
 

NightHawk

Well-known Member
Yeah just did that this second told them had power cut and router didn't come back on. If I told them about ports and dmz mode etc am sure they would not be keen to replace it unless I paid for it. Which of course I didn't lol

Cheers nh for getting a look at that for me anyways
No worries.

Are they sending you out a new one?
 

Henborg

Active Member
Yeah new router hub 2.0 this time means can do away with open reach box. Had to read contract tho have it half price till end of September anyways so happy enough with that.
 

theshrew

Active Member
Check your IP address on PS4 network settings by viewing connection status. If it matches, your PS4 should be in DMZ with open NAT.

If not put the correct IP address from your PS4 to the router page.

Delete all port forward settings too.

Ah so you need to delete other port forwards that have previously been added to the router or this won't work ?
 

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...

Latest News

AVForums Podcast: 20th January 2021
  • By Phil Hinton
  • Published
Netflix passes 200 million subscribers to end 2020
  • By Andy Bassett
  • Published
Cyrus Audio announces soundBuds2 in-ear headphones
  • By Andy Bassett
  • Published
Audio Research launches Reference 80S power amplifier
  • By Andy Bassett
  • Published
What's new on Netflix UK for February 2021
  • By Andy Bassett
  • Published
Top Bottom