Black Gold, mpeg2 decoding issue, lips seem out of sync but they are not?

b0rked

Standard Member
Hey all ( I'm not new here, just forgot my old account details and no longer have access to my work email:D ),

Recently hacked up my old system and built my HTPC, 400Gb, 1800XP, 768Mb, 9600XT, MCE, etc. I'm using VGA>Scart homemade cable with powerstrip running at 960*540. Today my 2 Sweetspot tuner cards came:)

The issue I am having is as follows:
The picture and the audio ARE in sync, the picture looks really good and very vibrant. The problem is peoples mouths seem, well, 'less defined' than through my freeview box, even tho I get a better resoloution through the HTPC. The result is a slight appearance of lips being out of sync, even tho they are not.

I found that with the Nvidia and PowerDVD mpeg2 decoders the problem is worse, I beleive this is because they try to 'improve' image quality. Adjusting the audio sync on the Nvidia codec proved that audio sync was not the issue. Using the Ligos mpeg2 decoder forund in the k-lite codec pack the problem is reduced, but still below my Sony freeview box. I think this decoder is better as it presents a more 'true' decoding of the bitstream. I tried running it through ffdshow, the results were on a par with the Ligos decoder, with slightly improved image quality using the various image filtering improvements.

Windows MCE is fully up to date, I have tried backdated ATI and current Cat drivers, these have no bearing on the situation. I have tried altering the ATI catalyst video playback settings, no result.

This is pretty frustrating! Surely other people have experienced this issue as it seems to be mpeg2 decoder related, although it may also be a Sweetspot issue:)

I am using the 5.17 drivers, my next move it to possible backdate to the 5.11 blackgold drivers - are there more up to date sweetspot drivers?

Does anyone else experience this issue, and more importantly has anyone resolved it:)?

At the moment I am considering trying a nebula card!

Thanks all.
 

Golfpunk

Active Member
I have found this, in my experience, down to the 50hz/60hz issue. The lips just look wrong but you can't quite put your finger on it.... pardon any pun :rolleyes:

I use a 360 as a extender and backing it off HD to PAL 50 sorts it out. Have you tried the reg hack to set 50hz for your MCE?
 

b0rked

Standard Member
Hi there,

Thanks for the reply:)

I just imported it into the registry, need to go do some other things so will test it out tomorrow:)

Can I ask: are you connected to your TV using the VGA>Scart or by some other mechanism? The reason I ask is I would expect either:
Powerstrip to enforce 25Hz ( = 50Hz?) as no other resoloutions are allowed
or
The TV to go a bit mad because I haven't tweaked 60Hz in powerstrip yet.

Whatcha reckon?
 

Golfpunk

Active Member
My 360 is connected by Component lead (which has a HD/TV switch on it). I am only using a Panny TX32 PD50 crt which supports Prog scan (480P/60). If the switch is set to use prog scan (HD - 60hz) the lips look wrong. When you set it to TV (PAL - 576i/50) the lips look correct (and the camera pans are not juddery).

The thing here is that we are both using analouge connections. I have never connected my Media Center direct to the TV as I have 6800GT which cannot do RGB scart.

HOpe this helps
 

b0rked

Standard Member
Hi:)

Thanks or listing your setup:) I ran with composite > TV and it seemed a little worse! However it was running at 60Hz so that may be why. I could only switch the refresh down to 48Hz and the image quality was way below par (imo).

The problem still appears to be there with the VGA>Scart, I suspect this is because MCE was running at 50Hz anyway. To test this theory I set powerstrip to 60Hz (or rather 30Hz) and the TV went way out of sync, leading me to beleive that the same would occur if MCE switched to 60Hz.

Incidentally ATI CCC reports a 60Hz setting but I think powerstrip just overwrites this.

I tried playing one of the recorded shows on my laptop and the sync issue is far worse! With DivX / XVid encodings the problem is not there at all (on my laptop, or with the HTPC > TV!). Does anyone know how the stream is recrded, does it go:
a) DVB card > Raw MPEG2 > Hard drive
or
b) DVB card > some raw binary stream > MPEG2 decoder (e.g. Nvidia / powerDVD) > Hard drive?

If it is a) then it could be the card.
If it is b) then it could be the card or the decoder, or I am getting the same results as everyone else but just being picky:)

I'm wondering if it could be the sweetspot (black gold) card? I am tempted to go to PC world and get a NOVA with a view to returning it to test it!

Any other ideas?

Thanks!
 

Golfpunk

Active Member
Composite will be worse - bottom of the food chain for Analouge connections. Component is the best. What display are you using? This may help us.

I have the nova t on my MCE and its a good card for the cash.

Of course, you could buy a Xbox 360 and network up to your MCE - problem solved! In a expensive kind of way.... :rolleyes:
 

b0rked

Standard Member
Hi there:)

I am connecting via VGA>Scart to a Daewoo widescreen CRT screen and the picture is really great! In fact better than via my Sony freeview box (however the freeview box does not 'blur' the lips). The odd thing is that the lips seemed 'blured' on my laptop too, however this may be a TFT / refresh rate issue, I will try later using a CRT monitor @ 50Hz.

I can't afford a 360 right now:) is there a better way to connect my PC to the SCART on my TV, could I pay more for a card and do say RGB>Scart or alike?

P.S. Does anyone know if the answer is a) or b) to my post above :)?

Thanks!
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom