Benq W2000 3D not working

gav_sw20

Active Member
I’ve had this projector for a couple of years and not watched a lot of 3D content. I vaguely remember watching TinTin three years ago and remember it being a faff getting a 3D image.

Went to watch Gravity 3D yesterday (Arcam AVR390, Panasonic UB420) and all I get on the projector screen is a Panasonic message about “not connected to a correct 3D output” or similar message. And then I can’t even get to the PLAY menu of the disc.

BENQ (firmware version 1.03) settings only allow me to change to Top/Bottor or Side/Side but even then I get the same message.

Does anyone have any ideas at all please?
 

unreel

Active Member
I've had similar 3D error messages on my Optoma projector with a Marantz Receiver and Cambridge Blu Ray player. Turning the Receiver and player on and off sorts it for me.

I leave the projector, on then I turn the receiver off and on then boot the blu ray player up.
 

gav_sw20

Active Member
I've had similar 3D error messages on my Optoma projector with a Marantz Receiver and Cambridge Blu Ray player. Turning the Receiver and player on and off sorts it for me.

I leave the projector, on then I turn the receiver off and on then boot the blu ray player up.
Thanks for the response, have tried this and still get the same issue.

Have also taken the AVR out of the equation and plugged a new HDMI cable directly from
The Projector to the Blu-Ray player.

A couple of photos if this helps:

PROJECTOR 3D OPTIONS:
AF9ECE7E-8F18-4F64-AF36-07DF4B10C6F6.jpeg

D65C226F-88A6-4BF9-994E-D567846A59D4.jpeg


PROJECTOR INFO:
7D0491C4-2038-4B06-AB93-3332AAA5E545.jpeg
 
Last edited:

gav_sw20

Active Member
UPDATE - Had a fiddle with some of the Blu-Ray player options and I’ve now got this working. Not a clue what I changed but now got Gravity in 3D to watch :)

Thanks again for the advice given.
 

The latest video from AVForums

Podcast: The Best TVs and Projectors of 2020, plus AV, TV Show & Movie News & Reviews
Top Bottom