• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Benq w1070 picture problems

Djcgamble

Novice Member
image.jpeg
image.jpeg
hay need some expert advice, I bought a benq w1070 projector about a year ago, last week the skin tones on people where blotch very white in areas and reds where the same dark in spots and blotchy lighter white in other areas, then things just got worse and all colours went and was unwatchable. Replaced the lamp on Monday had fixed the colour problem but I still have the patchy whitish skinntones and patchy reds? Any ideas
 
Last edited:

Grondath

Established Member
What is your video source? Looks almost like something running in a low colour depth from a PC?
 

Djcgamble

Novice Member
Source is from sky hd box running through a pioneer vsx920 receiver. I'm thinking its a problem with the lens since I replaced the lamp, waiting on Ben q to contact me Also noticed an aroura around some spots on the screen, it's my first projector so I haven't a clue. Was perfect up until last month.
 
Last edited:

Grondath

Established Member
Tried other sources, not through the amp, etc, just to be 100% sure it's the projector at fault?
 

Djcgamble

Novice Member
Tried other sources, not through the amp, etc, just to be 100% sure it's the projector at fault?
Tried there now still the same switched hdmi cables also to be sure and same problem with it.
 

Attachments

  • image.jpeg
    image.jpeg
    668.9 KB · Views: 88
  • image.jpeg
    image.jpeg
    666.2 KB · Views: 99
  • image.jpeg
    image.jpeg
    394.8 KB · Views: 83

cypher007

Established Member
looks like a signal process error. maybe a chip has gone. maybe try updating the firmware, as it could be corrupt somehow?
 

Djcgamble

Novice Member
Tried other sources, not through the amp, etc, just to be 100% sure it's the projector at fault?
Just off the phone to benq looks like the colour wheel could be the problem so has to be sent away for a fix, thanks for the help guys I'll let use know how I get on.
 

The latest video from AVForums

CES 2023 Round Up: New TV Lineups for 2023 from LG, Samsung, Panasonic, Hisense & TCL
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom