1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Benq 5120 problem?

Discussion in 'Projectors, Screens & Video Processors' started by Dillz, May 23, 2005.

  1. Dillz

    Dillz
    Active Member

    Joined:
    Feb 25, 2004
    Messages:
    236
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Gloucestershire
    Ratings:
    +8
    Hi,
    I have a BENQ 5120 projector which is now a week old, and for the third time it has switched itself off immediately after it's startup process. The last time it made a ticking noise and the lamp went off and the red lamp light came on. The first two times it just went back to standby.

    Anyone else had this problem?

    Thanks
     
  2. Darko

    Darko
    Well-known Member

    Joined:
    Apr 13, 2005
    Messages:
    3,778
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Caterham on the hill Surrey
    Ratings:
    +183
    Lo mate yup me and another fella had this same problem but dont panic and dont mess around with it
    If you have a look in the box you will find the warranty book and in it there is a UK number if you give them a bell they will swap it for you as they have a 15 day dead on arrival.

    Let us know how you get on bud

    Cheers Darko :thumbsup: :thumbsup: :thumbsup:
     
  3. Dillz

    Dillz
    Active Member

    Joined:
    Feb 25, 2004
    Messages:
    236
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Gloucestershire
    Ratings:
    +8
    Thanks. I think I'll give them a call. It's not actually DOA though. I now have 20 hours on the bulb and it has done it on three occassions since I have had it. I'll let you know how I get on.
    Thanks for replying.
     
  4. Dillz

    Dillz
    Active Member

    Joined:
    Feb 25, 2004
    Messages:
    236
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Gloucestershire
    Ratings:
    +8
    Thanks Darko. I phoned the BenQ warranty number and they just said box it up and they will do an on-site exchange, which will be next week sometime now.

    :thumbsup:
     
  5. Darko

    Darko
    Well-known Member

    Joined:
    Apr 13, 2005
    Messages:
    3,778
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Caterham on the hill Surrey
    Ratings:
    +183
    Yup it sure is a good service they provide I am glad I could be of help bud


    Darko
     
  6. JonLeach

    JonLeach
    Active Member

    Joined:
    Sep 17, 2002
    Messages:
    742
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Deepest Darkest Yorkshire
    Ratings:
    +22
    same fault as mine allthough it only happened once. when it did i have lost contrast /brightness or should i say i have gained brightness. i have had to send photies and now i have to send the bulb back and they will send a new one. hopefully it will sort it. i wonder if there is a problem with bulb life.


    Jon
     

Share This Page

Loading...