Question Beginning of Tracks messed up missing or don't start properly when playing Music through Android BubbleUPnP Cloud Qobuz to KEF X300AW DLNA speakers???

Tech_Guy

Active Member
So i have KEF X300AW DLNA with an ethernet connection to my router. Using BubbleUPnP on an Android Galaxy Note 9. I have Qobuz sublime + subscription. The beginning of some tracks do not start properly, and bits of the track are missing. Also i get an error when i press back or forward track advance. What could this be and can anybody help me pleeease ?
 

larkone

Distinguished Member
Re-boot the router, is you b/band good?
 

Tech_Guy

Active Member
Well i have FTCC Virgin Media 360MBPS. My router, it's a really good one. It's a Red DLINK DIR 890L AC 3200 Ultra Tri Band. My Router is less than 8 feet away with a CAT6E Ethernet cable.
 

Tech_Guy

Active Member
I can Stream 4K UHD to my Bedroom TV on the wall next to it, stream to my parents bedroom tv, and stream 4K UHD the kitchen tv.
 

Tech_Guy

Active Member
I don't know if this is anything to do with it but i skip to next track. Seek mode not supported (Code: 710)
 

larkone

Distinguished Member
Have you tired changing the QOS settings in the router to give your music streaming a higher priority?
 

Cebolla

Well-known Member
Given the buggy UPnP/DLNA streaming reputation of the newer Kef LS50W, there could well be an issue with X300AW misbehaving when it's being controlled as a UPnP/DLNA streamer, rather than a problem with its network connection and/or the rest of your network hardware.

You should try to see if you are getting similar problems with a simpler UPnP/DLNA controller app that hasn't so many configuration options as BubbleUPnP, in order to isolate the issue. For example, the mconnect Player app (free Lite version available for testing) also supports Qobuz but, unlike BubbleUPnP, has no options to transcode the streams - so always gets the controlled UPnP/DLNA renderer to stream the tracks directly from Qobuz's online server.

Test with the mconnect Player Lite app to see if you are getting the same problems, first with its Gapless > Gapless to Renderer setting switched off and then with the Gapless to Renderer setting switched on.
 
Last edited:

Tech_Guy

Active Member
Oh ok. Thanks for all the help and replies guys. I will try MConnect. I think i might have partially solved my problem maybe but not sure what option exactly changed it.

I switched the Individual UPnP/DLNA renderer settings "FFMpeg audio decoding to PCM" to never use for the KEF X300AWWIRELESS renderer. I could Play, Pause or Stop tracks before but could not "Seek on tap" or "Long press previous / next track".

Now the "Long press the previous / next track button works and changes tracks. All of the other render settings are switched off like mime checking, eventing, render polling rate.

So to summary. Heres the options i changed.

Local renderer. Disabled
FFMpeg audio decoding (local renderer) apply to non natively supported audio formats *WMA, ALAC, AIFF, DSD, OPUS, WAVPACK*
Everything else. Disabled

Individual UPnP renderer settings.
KEFX300AWWIRELESS
FFMpeg audio decoding. Never use
Everything else Disabled

Local and Cloud
Local media server. Enabled
Network name. Default
Advertise on Lan. Disabled
Proxy. Disabled

Show HiRes Info. Enabled
WiFi/Eth Audio quality. FLAC 24bits upto 96KHz
Do not display extracts. Enabled

Chromecast Transcoding. Default

Internet Access
Connectivity Notification. Enabled
Active on connection. Mobile/WiFi/Eth
Add to Android Library. Enabled

Music Playback transcoding. All default.
Lossless only. Enabled

Control
Wait for renderer in startup. Enabled
Start on boot. Enabled

Share to BubbleUPnP. All disabled

Resume playback. Disabled
Minimum duration. 15mins

Notification
Exit (X) button. Enabled
Volume step. 1

Control
Kill on inactivity. Disabled
Confirm app exit. Disabled
Volum keys. Enabled
Media keys. Enabled
Everything else disabled except send error reports

UPnP Tweaks
Gapless control. Disabled
Support shoutcast. Disabled
Mime-type checking. Disabled
Use eventing. Disabled
Render polling. 1000 (*Default is 900*)
Detect external stop. Disabled
UPnP action timeout. 60s
Blast alive messages. Enabled
Bubble UPnP server FFMpeg decoding- Enabled
 
Last edited:

Cebolla

Well-known Member
Individual UPnP renderer settings.
KEFX300AWWIRELESS
FFMpeg audio decoding. Never use
Everything else Disabled
Ok, this switches off gapless support as well transcoding of the Qobuz tracks (so the X300AW should now be playing Qobuz's tracks in their original FLAC format directly from the online server). If a UPnP renderer misbehaves when implementing the UPnP gapless playback support mechanism, the normally unhindered transition to the beginning of another track being played can be compromised, resulting in faulty playback effects similar to most of the ones you mentioned. The use of the ffmpeg as a transcoder in order to decode the FLAC tracks to (larger) uncompressed PCM tracks could make the problem worse, if not trigger it in the first place.

However, the Seek mode not supported (Code: 710) issue most likely simply means that the X300AW does not support track seek (so changing to another position in the track after it has started playing) in the first place. The X300AW's official DLNA test certificate appears to confirm this with seek reported as not supported across all the tested audio formats:
http://certification.dlna.org/certs/REG04080828.pdf
1600183953321.png


1600184106883.png

Sourced from:
DLNA product search to find DLNA Certified products
 
Last edited:

Tech_Guy

Active Member
Sorry i took so long to get back to you. I thought i fixed the issues for a while but i was playing Pink Floyd Delicate Sound of Thunder (2019 Remaster) last night in 96KHz 24Bit and was still getting terrible missing parts of beginnings of tracks, sometimes then the rest of the track plays without missing or skipping bits. It always seems to happen at the begginning of tracks and sometimes happens the first few secs to 30secs.
 

Cebolla

Well-known Member
Please test if you get the problem with the same Pink Floyd tracks provided by Qobuz when using the free mconnect Player Lite app (with its Gapless > Gapless to Renderer setting switched off) instead of the BubbleUPnP app.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom