BBC iPlayer UHD on QE85Q80T?

nigelbb

Distinguished Member
Has anyone else with an QE85Q80T had problems with UHD content on BBC iPlayer? I can play all regular content OK but if I select any UHD content I get the rotating circle and after around 45 seconds I get the message "Something went wrong playing this programme". Can I watch programmes in Ultra HD on my connected TV? | iPlayer help

There is a slight twist with my setup as I am in France & using a VPN to spoof a UK IP address. If I don't use the VPN this is the same message I get on all content on iPlayer. My network speed is decent at around 100Mbps down & 10Mbps up over 4G+. The TV firmware is the latest version 1497. As far as I know the iPlayer app is the latest version too.

Before I try using a different VPN or any other reconfiguration I would really like to know that it is a problem with my setup & not a problem with the TV so would like to hear from anyone who is successfully viewing UHD content on the iPlayer on the QE85Q80T.
 

nigelbb

Distinguished Member
Problem solved. The network speed was too slow.

I checked the network speed using the browser on the TV to go to www.speedtest.net & discovered that the speed using the VPN was variable & often below 25Mbps download which is the recommended speed for BBC UHD media. I switched to using an EE sim in my 4G router & then there is no need to use a VPN because the TV 'thinks' that it's in the UK. Download speeds on EE are 60Mbps or more & BBC UHD content plays perfectly.

Oddly enough my iPhone & laptop connected to the same VPN saw download speeds of 80-90Mbps but the TV only just managed 25Mbps although upload speed was OK at 18-20Mbps on all my devices.
 

The latest video from AVForums

Podcast: Sky Glass, Epson Laser Projectors plus Home Cinema Subwoofers and More…
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom