1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B&W DM604s3 Woofer Failure

Discussion in 'Home Cinema Speakers' started by Tommytutor, Oct 23, 2004.

  1. Tommytutor

    Tommytutor
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I've just experienced my second woofer failure in eight months. Both failures were identical with the tinsel lead becoming detached from the voice coil resulting in the wire lead breaking off due to the cone movement. Seems like a bad glue issue. Has anyone else had this happen? Just curious.

    Tom
     
  2. BestGear

    BestGear
    Active Member

    Joined:
    Oct 22, 2003
    Messages:
    1,158
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Ratings:
    +30
    Hui - thats bad news!!

    What did B&W say? That must be down to bad manufacture!!

    I have two sets of 604's - dread the day that happens!!

    What was the cost of the replacement unit? I think I would be fixing it first!!

    David
     
  3. Tommytutor

    Tommytutor
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi David, Both of the units were replaced under warranty so I don't know the cost of the woofer. If you try to repair them it is very difficult because the voice coil wire is so fine and covered with glue and I'm assuming shellac which makes it very hard to solder. The only way I could tell they were bad was with hard driving bass, I could hear the wire pinging on the aluminum cone. Just curious, how do you like your B&Ws and what did you compare them with at time of purchase? There doesn't seem to be much info on this site about them. Tom
     

Share This Page

Loading...